Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53547

Parallel sequential pipeline rendering appears distorted while jobs are running

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The parallel sequential pipeline rendering appears seriously distorted while jobs are running. Steps and even entire branches are missing. Sometimes nodes are rendered at the right between the parallel step and the end circle.

      At start things are looking well still:

      Now some stages are missing for the macOS agent:

      Now also the Android branch got lost. Interestingly the Windows branch still shows up although running on same agent:

      Finally it's all good again:

      Entire branches get lost when limiting the amount of jobs per agent to one. Failed to screenshot stages appearing right to the parallel stage this time, but can try again if needed.

        Attachments

        1. another ghost tail.png
          another ghost tail.png
          101 kB
        2. branches missing.png
          branches missing.png
          95 kB
        3. ghost tail.png
          ghost tail.png
          141 kB
        4. image-2018-09-13-10-05-39-675.png
          image-2018-09-13-10-05-39-675.png
          80 kB
        5. image-2018-09-13-10-07-05-681.png
          image-2018-09-13-10-07-05-681.png
          70 kB
        6. image-2019-01-09-16-13-27-139.png
          image-2019-01-09-16-13-27-139.png
          24 kB
        7. Jenkinsfile
          20 kB
        8. screenshot-1.png
          screenshot-1.png
          77 kB
        9. screenshot-2.png
          screenshot-2.png
          91 kB

          Issue Links

            Activity

            hasselmm Mathias Hasselmann created issue -
            hasselmm Mathias Hasselmann made changes -
            Field Original Value New Value
            Attachment image-2018-09-13-10-05-39-675.png [ 44466 ]
            hasselmm Mathias Hasselmann made changes -
            Attachment image-2018-09-13-10-07-05-681.png [ 44467 ]
            hasselmm Mathias Hasselmann made changes -
            Attachment screenshot-1.png [ 44468 ]
            hasselmm Mathias Hasselmann made changes -
            Description The parallel sequential pipeline rendering appears seriously distorted while jobs are running. Steps and even entire branches are missing. Sometimes nodes are rendered at the right between the parallel step and the end circle. The parallel sequential pipeline rendering appears seriously distorted while jobs are running. Steps and even entire branches are missing. Sometimes nodes are rendered at the right between the parallel step and the end circle.

            At start things are looking well still:

            !image-2018-09-13-10-05-39-675.png|thumbnail!

            Now some stages are missing for the macOS agent:

            !image-2018-09-13-10-07-05-681.png|thumbnail!

            Now also the Android branch got lost. Interestingly the Windows branch still shows up although running on same agent:

             !screenshot-1.png|thumbnail!

            Finally it's all good again:
            hasselmm Mathias Hasselmann made changes -
            Attachment screenshot-2.png [ 44469 ]
            hasselmm Mathias Hasselmann made changes -
            Description The parallel sequential pipeline rendering appears seriously distorted while jobs are running. Steps and even entire branches are missing. Sometimes nodes are rendered at the right between the parallel step and the end circle.

            At start things are looking well still:

            !image-2018-09-13-10-05-39-675.png|thumbnail!

            Now some stages are missing for the macOS agent:

            !image-2018-09-13-10-07-05-681.png|thumbnail!

            Now also the Android branch got lost. Interestingly the Windows branch still shows up although running on same agent:

             !screenshot-1.png|thumbnail!

            Finally it's all good again:
            The parallel sequential pipeline rendering appears seriously distorted while jobs are running. Steps and even entire branches are missing. Sometimes nodes are rendered at the right between the parallel step and the end circle.

            At start things are looking well still:

            !image-2018-09-13-10-05-39-675.png|thumbnail!

            Now some stages are missing for the macOS agent:

            !image-2018-09-13-10-07-05-681.png|thumbnail!

            Now also the Android branch got lost. Interestingly the Windows branch still shows up although running on same agent:

            !screenshot-1.png|thumbnail!

            Finally it's all good again:

            !screenshot-2.png|thumbnail!

            Entire branches get lost when limiting the amount of jobs per agent to one. Failed to screenshot stages appearing right to the parallel stage this time, but can try again if needed.
            hasselmm Mathias Hasselmann added a comment -

            Nicolae Pascu could you have a look at this and assign to the right person? Thank you.

            hasselmm Mathias Hasselmann added a comment -

            Also note how there is only one or even no blue circle indicating activity while actually multiple blue circles should be shown because multiple stages are active.

            olamy Olivier Lamy added a comment -

            any sample Jenkinsfile to reproduce?

            hasselmm Mathias Hasselmann made changes -
            Attachment Jenkinsfile [ 44478 ]
            hasselmm Mathias Hasselmann added a comment -

            Attached the full Jenkinsfile. Guess it's best to see the full picture.

            hasselmm Mathias Hasselmann made changes -
            Attachment branches missing.png [ 44479 ]
            hasselmm Mathias Hasselmann added a comment - - edited

            Just had the pleasure to catch a build with parallel branches missing in the status:

            hasselmm Mathias Hasselmann made changes -
            Attachment ghost tail.png [ 44480 ]
            hasselmm Mathias Hasselmann added a comment -

            We are lucky today, ghost tail:

            hasselmm Mathias Hasselmann made changes -
            Attachment another ghost tail.png [ 44484 ]
            hasselmm Mathias Hasselmann added a comment -

            Another ghost tail:

            olamy Olivier Lamy made changes -
            Labels blueocean-backend
            hasselmm Mathias Hasselmann added a comment -

            Potentially caused by JENKINS-53311. Observing.

            hasselmm Mathias Hasselmann made changes -
            Link This issue relates to JENKINS-53311 [ JENKINS-53311 ]
            olamy Olivier Lamy made changes -
            Link This issue duplicates JENKINS-53311 [ JENKINS-53311 ]
            olamy Olivier Lamy added a comment -

            dup of JENKINS-53311

            olamy Olivier Lamy made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Assignee Olivier Lamy [ olamy ]
            Resolution Fixed [ 1 ]
            hasselmm Mathias Hasselmann added a comment - - edited

            Bad luck: Things look much better now, but there still are entire branches disappearing, just as in the following screenshot, where the entire Android branch got lost:

            hasselmm Mathias Hasselmann made changes -
            Resolution Fixed [ 1 ]
            Status Closed [ 6 ] Reopened [ 4 ]
            zakharovdi Denis Zakharov made changes -
            Attachment image-2019-01-09-16-13-27-139.png [ 45613 ]

              People

              • Assignee:
                olamy Olivier Lamy
                Reporter:
                hasselmm Mathias Hasselmann
              • Votes:
                4 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated: