Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53729

Regression HyperlinkNote serialization: serialVersionUID

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      JENKINS-53016 changed the automatically computed serialVersionUID for HyperlinkNote (ModelHyperlinkNote was not affected), which meant that hyperlinks in build logs created in Jenkins 2.138 or older could not be viewed correctly in Jenkins 2.139 and newer. We should restore the previous serialVersionUID so that those hyperlinks can be viewed correctly, though it will break compatibility for the builds between 2.139 and the version in which this fix is released.

      There is no reason to backport this fix, because JENKINS-53016 is not included in the 2.138.x LTS release line.

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev created issue -
            dnusbaum Devin Nusbaum made changes -
            Field Original Value New Value
            Assignee Devin Nusbaum [ dnusbaum ]
            dnusbaum Devin Nusbaum made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            dnusbaum Devin Nusbaum made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            dnusbaum Devin Nusbaum made changes -
            Status In Review [ 10005 ] In Progress [ 3 ]
            dnusbaum Devin Nusbaum made changes -
            Status In Progress [ 3 ] Open [ 1 ]
            dnusbaum Devin Nusbaum made changes -
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            Resolution Fixed [ 1 ]
            dnusbaum Devin Nusbaum made changes -
            Link This issue relates to JENKINS-53016 [ JENKINS-53016 ]
            dnusbaum Devin Nusbaum made changes -
            Description Placeholder for [https://github.com/jenkinsci/jenkins/pull/3613] from [~dnusbaum] JENKINS-53016 changed the automatically computed {{serialVersionUID}} for {{HyperlinkNote}} ({{ModelHyperlinkNote}} was not affected), which meant that hyperlinks in build logs created in Jenkins 2.138 or older could not be viewed correctly in Jenkins 2.139 and newer. We should restore the previous {{serialVersionUID}} so that those hyperlinks can be viewed correctly, though it will break compatibility for the builds between 2.139 and the version in which this fix is released.

            There is no reason to backport this fix, because JENKINS-53016 is not included in the 2.138.x LTS release line.
            dnusbaum Devin Nusbaum made changes -
            Remote Link This issue links to "jenkinsci/jenkins#3613 (Web Link)" [ 21836 ]
            danielbeck Daniel Beck added a comment -

            Addressed in 2.143.

            danielbeck Daniel Beck made changes -
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]

              People

              • Assignee:
                dnusbaum Devin Nusbaum
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: