Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53861

Jenkins loses all InfluxDb targets in Manage Jenkins > Configure System after restart.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: influxdb-plugin
    • Labels:
    • Environment:
      Mac OS X 10.13.6 x86_64
      Oracle jdk1.8.0_111
      jenkins:2.121.2
      influxdb:1.19
    • Similar Issues:

      Description

      I have got the following behavior with the plugin. I have created new influxdb target in Manage Jenkins > Configure System and after that one became available for "Publish build data to InfluxDb target" in my job configuration. But when I have restarted aplication, Jenkins lost all InfluxDb targets in Manage Jenkins > Configure System.

       

      Steps to reproduce the issue

      1. clean JENKINS_HOME (rm -rf ~/.jenkins)
      2. java -jar jenkins.war (instal jenkins using default configuration)
      3. install influxdb plugin via Manage Jenkins > Manage Plugins
      4. restart jenkins (<jenkins_url>/restart)
      5. go to Manage Jenkins > Configure System, create influxdb target and click Save. The target is available for Freestyle project.
      6. restart jenkins (<jenkins_url>/restart)
      7. go to Manage Jenkins > Configure System. Influxdb target configuration is unavailable.

       

        Attachments

          Activity

          aleksisimell Aleksi Simell added a comment -

          This was caused by a `transient` CopyOnWriteList for InfluxDB targets used in the DescriptorImpl class. Jenkins pipelines demands objects to be serializable, which CopyOnWriteList is not. Non-serializable object changed to a serializable object and removed `transient` from the target list definition. This change should fix this issue and will be available in the next release.


            People

            • Assignee:
              aleksisimell Aleksi Simell
              Reporter:
              pavel_shchetska Pavel Shchetska
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: