Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53985

Login to ALM Server at https://xxx/qcbin/ failed. Status Code: 302

    Details

    • Similar Issues:

      Description

      It is not possible to connect to HP ALM server using the above mentioned pluigin.

      INFO: 'Upload test result to ALM' Post Build Step is being invoked by xxx.
      INFO: 1 test result file found.
      INFO: Start to upload C:\xx\xx\xx\xx\builds\16\testng\testng-results.xml
      INFO: Start to parse file: C:\xx\xx\xx\xx\builds\16\testng\testng-results.xml
      INFO: parse resut file succeed.
      INFO: Start to login to ALM Server.
      Start login to ALM server.
      Login to ALM Server at https://xxx/qcbin/ failed. Status Code: 302
      WARN: there's exception while uploading C:\xx\xx\xx\xx\builds\16\testng\testng-results.xml.
      INFO: 'Upload test result to ALM' Completed.
      Build step 'Upload test result to ALM' changed build result to UNSTABLE
      Finished: UNSTABLE

        Attachments

          Activity

          Hide
          roy_lu Roy Lu added a comment -

          It mainly because of proxy. Can you visit ALM from the machine where you build the jenkins job?

          Show
          roy_lu Roy Lu added a comment - It mainly because of proxy. Can you visit ALM from the machine where you build the jenkins job?
          Hide
          oschuhmacher Oliver Schuhmacher added a comment -

          Hi Roy,
          proxy settings are fine in Jenkins and on the machine itself.
          I'm able to open ALM in the browser.
          It is also possible for other plugins (e.g. Bumblebee) to connect to ALM from the Jenkins server.
          Are you fetching the proxy settings from the Jenkins configuration?
          Or do you use the system settings?
          Kind regards
          Oliver

          Show
          oschuhmacher Oliver Schuhmacher added a comment - Hi Roy, proxy settings are fine in Jenkins and on the machine itself. I'm able to open ALM in the browser. It is also possible for other plugins (e.g. Bumblebee) to connect to ALM from the Jenkins server. Are you fetching the proxy settings from the Jenkins configuration? Or do you use the system settings? Kind regards Oliver
          Hide
          roy_lu Roy Lu added a comment -

          Hi Oliver Schuhmacher,

          In 5.5 it should be using Jenkins proxy configuration. What's the version are you using?

          Show
          roy_lu Roy Lu added a comment - Hi Oliver Schuhmacher , In 5.5 it should be using Jenkins proxy configuration. What's the version are you using?
          Hide
          oschuhmacher Oliver Schuhmacher added a comment -

          Hi Roy Lu,

          I've installed the plugin in version 5.5

          Show
          oschuhmacher Oliver Schuhmacher added a comment - Hi Roy Lu, I've installed the plugin in version 5.5
          Hide
          roy_lu Roy Lu added a comment -

          Hi Oliver Schuhmacher,

          Is there any proxy been set in your browser? If yes, set the proxy in Jenkins proxy. If no, we may need a session to look into it. But in my experience, all the 302 issues I've met are because of proxy.

          Show
          roy_lu Roy Lu added a comment - Hi Oliver Schuhmacher , Is there any proxy been set in your browser? If yes, set the proxy in Jenkins proxy. If no, we may need a session to look into it. But in my experience, all the 302 issues I've met are because of proxy.
          Hide
          roy_lu Roy Lu added a comment -

          Closing it for no response for a long time.

          Show
          roy_lu Roy Lu added a comment - Closing it for no response for a long time.

            People

            • Assignee:
              roy_lu Roy Lu
              Reporter:
              oschuhmacher Oliver Schuhmacher
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: