Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54005

Trying to unexport an object that's already unexported (is back)

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins 2.141 -(remoting 3.26)
      kafka-remoting-plugin compiled against remoting 3.26
    • Similar Issues:
    • Released As:
      Remoting 3.28

      Description

      I thought this was fixed in remoting 3.26 under https://issues.jenkins-ci.org/browse/JENKINS-42533

      But today I got this stack trace again when one of my kafka  nodes was idle  (not running any job) just out of the blue it got

       

       INFO: ConnectedINFO: Connected[Channel reader thread: planet] INFO org.apache.kafka.clients.Metadata - Cluster ID: isxhuhJhRGGNrKyNAeNZHg[Channel reader thread: planet] INFO org.apache.kafka.clients.consumer.internals.AbstractCoordinator - [Consumer clientId=consumer-2, groupId=jenkinssecure.8081.planet-id] Discovered group coordinator sydjenkikafka01.al.com.au:9092 (id: 2147483647 rack: null)[kafka-producer-network-thread | producer-2] INFO org.apache.kafka.clients.Metadata - Cluster ID: isxhuhJhRGGNrKyNAeNZHgOct 11, 2018 3:42:18 PM org.jenkinsci.remoting.util.AnonymousClassWarnings warnWARNING: Attempt to (de-)serialize anonymous class net.bull.javamelody.RemoteCallHelper$1; see: https://jenkins.io/redirect/serialization-of-anonymous-classes/
      
      Oct 11, 2018 3:43:43 PM hudson.remoting.ExportTable unexportByOidS
      EVERE: Trying to unexport an object that's already unexportedjava.util.concurrent.ExecutionException: Invalid object ID 2 iota=3 at hudson.remoting.ExportTable.diagnoseInvalidObjectId(ExportTable.java:478) at hudson.remoting.ExportTable.unexportByOid(ExportTable.java:516) at hudson.remoting.Channel.unexport(Channel.java:803) at hudson.remoting.Channel.unexport(Channel.java:793) at hudson.remoting.UnexportCommand.execute(UnexportCommand.java:49) at hudson.remoting.Channel$1.handle(Channel.java:565) at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:87)Caused by: java.lang.Exception: Object was recently deallocated    #2 (ref.0) : object=null type=hudson.remoting.RemoteClassLoader$ClassLoaderProxy interfaces=[hudson.remoting.RemoteClassLoader$IClassLoader]      Created at Thu Oct 11 15:42:13 AEDT 2018     at hudson.remoting.ExportTable$Entry.<init>(ExportTable.java:114)     at hudson.remoting.ExportTable.export(ExportTable.java:365)

       complete log attached.

      Note the node did not stop working, at least I was able to run jobs after I noticed the stack trace.

       

        Attachments

          Activity

          jthompson Jeff Thompson added a comment -

          This is the same sort of thing as before, but just showing up in a different place in the code. It's a matter of a log message having too high of a severity and doesn't indicate any real problem by itself. When I get a chance, I'll decrease the log severity like we've done with the other similar cases.

          Thanks for reporting.

          fnaum Federico Naum added a comment -

          Thank you Jeff, there is no rush at all

          jthompson Jeff Thompson added a comment -

          PR is merged. I'll get it out in the next release when I can.

          fnaum Federico Naum added a comment -

          Thank you!

          Appreciated

          jthompson Jeff Thompson added a comment -

          This will be picked up by a Jenkins weekly build soon.


            People

            • Assignee:
              jthompson Jeff Thompson
              Reporter:
              fnaum Federico Naum
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: