Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54100

Need plugin that has incompatible format from one version to the next to test evergreen snapshot restore

    XMLWordPrintable

    Details

    • Sprint:
      Evergreen - Milestone 2
    • Similar Issues:

      Description

      Problem statement

      To test JENKINS-54057, i.e. the fact our rollback system wrt. data snapshotting does work, we need something that would actually make Jenkins fail to start if data is left on next UL state for instance.

      Expected

      We need to find or create a plugin that has a incompatible format change from version N to N+1. This way, we can include this in the upgrade/rollback test, and check that Jenkins does fail to restart after rollback.

        Attachments

          Issue Links

            Activity

            Hide
            batmat Baptiste Mathus added a comment -

            Experimenting with https://github.com/jenkinsci/non-dynamic-hello-world-plugin, this seems like an idea testing plugin.

            Show
            batmat Baptiste Mathus added a comment - Experimenting with https://github.com/jenkinsci/non-dynamic-hello-world-plugin , this seems like an idea testing plugin.
            Hide
            batmat Baptiste Mathus added a comment -

            I don't think I'll need to do this this way finally.

            Show
            batmat Baptiste Mathus added a comment - I don't think I'll need to do this this way finally.

              People

              • Assignee:
                batmat Baptiste Mathus
                Reporter:
                batmat Baptiste Mathus
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: