Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54167

Hide Evergreen Jenkins plugin for non-evergreen installs

    Details

    • Similar Issues:
    • Sprint:
      Evergreen - Milestone 2

      Description

      Problem statement

      It should be clear that the Evergreen Jenkins plugin is not designed to be installed on a non-evergreen Jenkins instance.
      But currently for some reason, despite the fact I wrote
      Jenkins Evergreen Plugin - Note: you should generally never install this plugin yourself.

      In the plugin manager, it looks like:

      Expected behavior

      The end of that message should be visible. I suppose there's a tokenization that cuts after the hyphen or something. Probably we just remove it and that's enough.

        Attachments

          Issue Links

            Activity

            batmat Baptiste Mathus created issue -
            batmat Baptiste Mathus made changes -
            Field Original Value New Value
            Attachment screenshot-1.png [ 44822 ]
            batmat Baptiste Mathus made changes -
            Description h3. Problem statement

            It should be clear that the Evergreen Jenkins plugin is not designed to be install on a non-evergreen Jenkins instance.
            But currently for some reason, despite the fact I wrote

            h4. Expected behavior

            h3. Problem statement

            It should be clear that the Evergreen Jenkins plugin is not designed to be installed on a non-evergreen Jenkins instance.
            But currently for some reason, despite the fact I wrote
            {{Jenkins Evergreen Plugin - Note: you should generally never install this plugin yourself.}}

            In the plugin manager, it looks like:

             !screenshot-1.png!

            h4. Expected behavior

            The end of that message should be visible. I suppose there's a tokenization that cuts after the hyphen or something. Probably we just remove it and that's enough.
            batmat Baptiste Mathus made changes -
            Description h3. Problem statement

            It should be clear that the Evergreen Jenkins plugin is not designed to be installed on a non-evergreen Jenkins instance.
            But currently for some reason, despite the fact I wrote
            {{Jenkins Evergreen Plugin - Note: you should generally never install this plugin yourself.}}

            In the plugin manager, it looks like:

             !screenshot-1.png!

            h4. Expected behavior

            The end of that message should be visible. I suppose there's a tokenization that cuts after the hyphen or something. Probably we just remove it and that's enough.
            h3. Problem statement

            It should be clear that the Evergreen Jenkins plugin is not designed to be installed on a non-evergreen Jenkins instance.
            But currently for some reason, [despite the fact I wrote|https://github.com/jenkinsci/evergreen-plugin/blob/evergreen-0.9/pom.xml]
            {{Jenkins Evergreen Plugin - Note: you should generally never install this plugin yourself.}}

            In the plugin manager, it looks like:

             !screenshot-1.png!

            h4. Expected behavior

            The end of that message should be visible. I suppose there's a tokenization that cuts after the hyphen or something. Probably we just remove it and that's enough.
            batmat Baptiste Mathus made changes -
            Assignee R. Tyler Croy [ rtyler ] Baptiste Mathus [ batmat ]
            batmat Baptiste Mathus made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            batmat Baptiste Mathus added a comment -

            Daniel just told me that now pom.xml is mostly ignored, so this is extracted from index.jelly. Fixing.

            batmat Baptiste Mathus made changes -
            Remote Link This issue links to "PR (Web Link)" [ 21940 ]
            batmat Baptiste Mathus made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            batmat Baptiste Mathus added a comment -

            Note: again thanks to Daniel I finally chose an even better path: PR has been filed against the UC generation repo to hide evergreen Jenkins plugin.
            As we're using anyway only incrementals releases on evergreen distribution, this is fine. This Jenkins plugin becomes invisible to standard installs, which if what we want.

            batmat Baptiste Mathus made changes -
            Summary Fix plugin description in the update center Hide Evergreen Jenkins plugin for non-evergreen installs
            batmat Baptiste Mathus made changes -
            Status In Review [ 10005 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]

              People

              • Assignee:
                batmat Baptiste Mathus
                Reporter:
                batmat Baptiste Mathus
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: