Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54426

Jenkinsfile Runner fails on Java 11: NoClassDefFoundError: java.sql.Date

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      java.lang.NoClassDefFoundError: java.sql.Date at org.apache.commons.beanutils.ConvertUtilsBean.class$(ConvertUtilsBean.java:157) at org.apache.commons.beanutils.ConvertUtilsBean.registerOther(ConvertUtilsBean.java:708) at org.apache.commons.beanutils.ConvertUtilsBean.deregister(ConvertUtilsBean.java:580) at org.apache.commons.beanutils.ConvertUtilsBean.<init>(ConvertUtilsBean.java:164) at org.kohsuke.stapler.Stapler.<clinit>(Stapler.java:1065) at hudson.model.Node$Mode.<clinit>(Node.java:597) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:566) at java.base/java.lang.Class.getEnumConstantsShared(Class.java:3554) at java.base/java.lang.Class.getEnumConstants(Class.java:3530) at jenkins.model.Jenkins.<clinit>(Jenkins.java:5191) at hudson.ExtensionList.lookup(ExtensionList.java:432) at hudson.model.User.clear(User.java:717) at io.jenkins.jenkinsfile.runner.JenkinsRule.before(JenkinsRule.java:251) at io.jenkins.jenkinsfile.runner.JenkinsfileRunnerRule.before(JenkinsfileRunnerRule.java:76) at io.jenkins.jenkinsfile.runner.JenkinsfileRunnerRule$1.evaluate(JenkinsfileRunnerRule.java:113) at io.jenkins.jenkinsfile.runner.App.run(App.java:32) at io.jenkins.jenkinsfile.runner.bootstrap.Bootstrap.run(Bootstrap.java:166) at io.jenkins.jenkinsfile.runner.bootstrap.Bootstrap.main(Bootstrap.java:68) Exception in thread "Executing main" java.lang.NoClassDefFoundError: java.sql.Date at org.apache.commons.beanutils.ConvertUtilsBean.class$(ConvertUtilsBean.java:157) at org.apache.commons.beanutils.ConvertUtilsBean.registerOther(ConvertUtilsBean.java:708) at org.apache.commons.beanutils.ConvertUtilsBean.deregister(ConvertUtilsBean.java:580) at org.apache.commons.beanutils.ConvertUtilsBean.<init>(ConvertUtilsBean.java:164) at org.kohsuke.stapler.Stapler.<clinit>(Stapler.java:1065) at hudson.model.Node$Mode.<clinit>(Node.java:597) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:566) at java.base/java.lang.Class.getEnumConstantsShared(Class.java:3554) at java.base/java.lang.Class.getEnumConstants(Class.java:3530) at jenkins.model.Jenkins.<clinit>(Jenkins.java:5191) at hudson.ExtensionList.lookup(ExtensionList.java:432) at hudson.model.User.clear(User.java:717) at io.jenkins.jenkinsfile.runner.JenkinsRule.before(JenkinsRule.java:251) at io.jenkins.jenkinsfile.runner.JenkinsfileRunnerRule.before(JenkinsfileRunnerRule.java:76) at io.jenkins.jenkinsfile.runner.JenkinsfileRunnerRule$1.evaluate(JenkinsfileRunnerRule.java:113) at io.jenkins.jenkinsfile.runner.App.run(App.java:32) at io.jenkins.jenkinsfile.runner.bootstrap.Bootstrap.run(Bootstrap.java:166) at io.jenkins.jenkinsfile.runner.bootstrap.Bootstrap.main(Bootstrap.java:68)
      

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev created issue -
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Epic Link JENKINS-54342 [ 194995 ]
            oleg_nenashev Oleg Nenashev made changes -
            Labels java11
            oleg_nenashev Oleg Nenashev added a comment -

            Same as JENKINS-54355 ?

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue relates to JENKINS-54355 [ JENKINS-54355 ]
            oleg_nenashev Oleg Nenashev added a comment - - edited

            Likely it's caused by the same cause as https://bugs.openjdk.java.net/browse/JDK-8161269. But it is closed as "Not a defect"

            oleg_nenashev Oleg Nenashev added a comment -
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue relates to JENKINS-40689 [ JENKINS-40689 ]
            oleg_nenashev Oleg Nenashev made changes -
            Epic Link JENKINS-54342 [ 194995 ]
            oleg_nenashev Oleg Nenashev made changes -
            Summary Jenkinsfile Runner fails on Java 11 Jenkinsfile Runner fails on Java 11: NoClassDefFoundError: java.sql.Date
            oleg_nenashev Oleg Nenashev made changes -
            Epic Link JENKINS-54905 [ 195912 ]
            oleg_nenashev Oleg Nenashev made changes -
            Labels java11 java11 java11-compatibility
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue relates to JENKINS-54957 [ JENKINS-54957 ]
            vilacides Isa Vilacides made changes -
            Assignee Oleg Nenashev [ oleg_nenashev ]
            batmat Baptiste Mathus made changes -
            Labels java11 java11-compatibility java11 java11-compatibility triaged
            batmat Baptiste Mathus added a comment -

            I think we "simply" need to add the java.sql module ASAP. Probably we'll do that next week or so. Cc Adrien Lecharpentier

            batmat Baptiste Mathus made changes -
            Labels java11 java11-compatibility triaged java11 java11-compatibility
            batmat Baptiste Mathus made changes -
            Labels java11 java11-compatibility java11 java11-compatibility scrub triaged
            vilacides Isa Vilacides added a comment -

            It seems like that was done in https://github.com/jenkinsci/jenkinsfile-runner/pull/41/files#diff-2cf0e01ded4fe6a729f0ff81e0a70f7aR24

             

            Baptiste Mathus recommendation is to do it upstream in the docker image. This has to be still tested.

            vilacides Isa Vilacides made changes -
            Labels java11 java11-compatibility scrub triaged java11 java11-compatibility triaged
            egutierrez Evaristo Gutierrez made changes -
            Assignee Evaristo Gutierrez [ egutierrez ]
            egutierrez Evaristo Gutierrez made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            egutierrez Evaristo Gutierrez made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue relates to JENKINS-55641 [ JENKINS-55641 ]
            egutierrez Evaristo Gutierrez made changes -
            Status In Review [ 10005 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue relates to JENKINS-55653 [ JENKINS-55653 ]

              People

              • Assignee:
                egutierrez Evaristo Gutierrez
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: