Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54486

Not created JIRA issue after build failed

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: jira-plugin
    • Labels:
      None
    • Similar Issues:

      Description

       

      When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

      Although build result failed, but i couldn't  created Jira issue, 

      There is no any log information why not created issue. Please could you help to me ?

      Thanks

       

      Jenkins version  2.138.1

      Jira plugin version 3.0.5

      Jira integration for jenkins  version 3.3.0

      Jira version 7.9.2

        Attachments

          Activity

          betulaslan Betul Aslan created issue -
          betulaslan Betul Aslan made changes -
          Field Original Value New Value
          Summary Jira create issue was occurred for last completed build result in jenkins job not occured according to last build failed Jira create issue to created for last completed build result in jenkins job not created according to last build failed
          betulaslan Betul Aslan made changes -
          Description  

          When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

          !image-2018-11-06-13-48-36-485.png!

          Although build result failed, but i couldn't  created Jira issue, because Jira issue was occurred according to last build completed result. So last completed build result always successful.  How i can change for create issue according to last failed build.

          !image-2018-11-06-13-53-31-157.png!

           

          Jenkins version  2.138.1

          Jira plugin version 3.0.3

          Jira integration for jenkins  version 3.2.0

          Jira version 7.9.2
           

          When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

          !image-2018-11-06-13-48-36-485.png!

          Although build result failed, but i couldn't  created Jira issue, because Jira issue was created according to last build completed result. So last completed build result always successful.  How i can change for create issue according to last failed build.

          !image-2018-11-06-13-53-31-157.png!

           

          Jenkins version  2.138.1

          Jira plugin version 3.0.3

          Jira integration for jenkins  version 3.2.0

          Jira version 7.9.2
          betulaslan Betul Aslan made changes -
          Assignee Erina Gomi [ 0000144223 ]
          betulaslan Betul Aslan made changes -
          Assignee Erina Gomi [ 0000144223 ]
          betulaslan Betul Aslan made changes -
          Assignee Kalyanram Adiraju [ 1226 ]
          betulaslan Betul Aslan made changes -
          Assignee Kalyanram Adiraju [ 1226 ]
          betulaslan Betul Aslan made changes -
          Assignee Betul Aslan [ betulaslan ]
          betulaslan Betul Aslan made changes -
          Assignee Betul Aslan [ betulaslan ] Olivier Lamy [ olamy ]
          betulaslan Betul Aslan made changes -
          Summary Jira create issue to created for last completed build result in jenkins job not created according to last build failed Not created JIRA issue after build failed
          betulaslan Betul Aslan made changes -
          Description  

          When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

          !image-2018-11-06-13-48-36-485.png!

          Although build result failed, but i couldn't  created Jira issue, because Jira issue was created according to last build completed result. So last completed build result always successful.  How i can change for create issue according to last failed build.

          !image-2018-11-06-13-53-31-157.png!

           

          Jenkins version  2.138.1

          Jira plugin version 3.0.3

          Jira integration for jenkins  version 3.2.0

          Jira version 7.9.2
           

          When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

          !image-2018-11-06-13-48-36-485.png!

          Although build result failed, but i couldn't  created Jira issue, 

          There is no any log information why not created issue. Please could you help to me ?

          Thanks

           

          Jenkins version  2.138.1

          Jira plugin version 3.0.3

          Jira integration for jenkins  version 3.2.0

          Jira version 7.9.2
          betulaslan Betul Aslan made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          betulaslan Betul Aslan made changes -
          Description  

          When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

          !image-2018-11-06-13-48-36-485.png!

          Although build result failed, but i couldn't  created Jira issue, 

          There is no any log information why not created issue. Please could you help to me ?

          Thanks

           

          Jenkins version  2.138.1

          Jira plugin version 3.0.3

          Jira integration for jenkins  version 3.2.0

          Jira version 7.9.2
           

          When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

          !image-2018-11-06-13-48-36-485.png!

          Although build result failed, but i couldn't  created Jira issue, 

          There is no any log information why not created issue. Please could you help to me ?

          Thanks

           

          Jenkins version  2.138.1

          Jira plugin version 3.0.5

          Jira integration for jenkins  version 3.2.0

          Jira version 7.9.2
          betulaslan Betul Aslan made changes -
          Description  

          When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

          !image-2018-11-06-13-48-36-485.png!

          Although build result failed, but i couldn't  created Jira issue, 

          There is no any log information why not created issue. Please could you help to me ?

          Thanks

           

          Jenkins version  2.138.1

          Jira plugin version 3.0.5

          Jira integration for jenkins  version 3.2.0

          Jira version 7.9.2
           

          When i want to create new Jira issue, after build fail in jenkins job,  always given same output just like below.

          !image-2018-11-06-13-48-36-485.png!

          Although build result failed, but i couldn't  created Jira issue, 

          There is no any log information why not created issue. Please could you help to me ?

          Thanks

           

          Jenkins version  2.138.1

          Jira plugin version 3.0.5

          Jira integration for jenkins  version 3.3.0

          Jira version 7.9.2
          falcon benoit guerin added a comment -

          Duplicate of JENKINS-57695 ?

          warden Radek Antoniuk added a comment -

          I don't think so as here we don't have any NPE. Interestingly the reporter mentions two plugins for JIRA, one is the open source one (v. 3.0.5) and the other one is (I'm assuming) the Marvellution plugin. So as a first shot, I'd propose disabling one of the plugins, configuring the other one and checking if you get the correct results as they might interfere with each other.

          warden Radek Antoniuk made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          warden Radek Antoniuk made changes -
          Assignee Olivier Lamy [ olamy ]
          warden Radek Antoniuk made changes -
          Labels build jenkins jira plugin
          warden Radek Antoniuk made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Cannot Reproduce [ 5 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              betulaslan Betul Aslan
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: