Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54499

Loosing connection to Docker container

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: docker-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.138.1 Running on Ubuntu 16.04
      Docker Plugin: 1.1.5
      Docker version: 17.09.0-ce, build afdb6d4
    • Similar Issues:

      Description

      Hello

      We are seeing the following issue:

       

      ERROR: Build step failed with exception
      java.lang.NullPointerException: no workspace from node io.jenkins.docker.DockerTransientNode[1604-JDK8-00001uywz3thf] which is computer DockerComputer{name=1604-JDK8-00001uywz3thf, slave=io.jenkins.docker.DockerTransientNode[1604-JDK8-00001uywz3thf]} and has channel null
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:88)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:66)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.build(MavenModuleSetBuild.java:945)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:896)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
      at hudson.model.Run.execute(Run.java:1815)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
      at hudson.model.ResourceController.execute(ResourceController.java:97)
      at hudson.model.Executor.run(Executor.java:429)
      Build step 'Execute shell' marked build as failure
      ERROR: Failed to parse POMs
      java.io.IOException: Backing channel '1604-JDK8-00001uywz3thf' is disconnected.
      at hudson.remoting.RemoteInvocationHandler.channelOrFail(RemoteInvocationHandler.java:214)
      at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:283)
      at com.sun.proxy.$Proxy73.isAlive(Unknown Source)
      at hudson.Launcher$RemoteLauncher$ProcImpl.isAlive(Launcher.java:1143)
      at hudson.maven.ProcessCache$MavenProcess.call(ProcessCache.java:166)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:879)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
      at hudson.model.Run.execute(Run.java:1815)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
      at hudson.model.ResourceController.execute(ResourceController.java:97)
      at hudson.model.Executor.run(Executor.java:429)
      Caused by: java.io.IOException: Expected 8 bytes application/vnd.docker.raw-stream header, got 2
      at io.jenkins.docker.client.DockerMultiplexedInputStream.readInternal(DockerMultiplexedInputStream.java:45)
      at io.jenkins.docker.client.DockerMultiplexedInputStream.read(DockerMultiplexedInputStream.java:25)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:91)
      at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
      at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
      at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:39)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:35)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:63)

        Attachments

          Issue Links

            Activity

            pjdarton pjdarton added a comment -

            This was fixed in PR-693 and that was released in version 1.1.6


              People

              • Assignee:
                Unassigned
                Reporter:
                saml Samuel Lopez
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: