Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54530

Upgrade mavenMinimalVersion from 3.1.0 to at least 3.5.0 (later is better)

    XMLWordPrintable

    Details

    • Similar Issues:

      Attachments

        Issue Links

          Activity

          Hide
          ianw Ian Williams added a comment -

          Fully agree on dropping maven2 support as EOL, but raising minimal version requires justification. Many large enterprises have large legacy codebases built on maven 3.1.1 (and JDK 6).

          An arbitrary change to minimal version will have negative impacts across many plugins, effectively freezing our installed Jenkins configuration.

          I hear the "buts" - using jdk 6 and M3.1.1 also has repercussions, but is there a justifiable reason to raise the minimal version ?

          Show
          ianw Ian Williams added a comment - Fully agree on dropping maven2 support as EOL, but raising minimal version requires justification. Many large enterprises have large legacy codebases built on maven 3.1.1 (and JDK 6). An arbitrary change to minimal version will have negative impacts across many plugins, effectively freezing our installed Jenkins configuration. I hear the "buts" - using jdk 6 and M3.1.1 also has repercussions, but is there a justifiable reason to raise the minimal version ?

            People

            • Assignee:
              olamy Olivier Lamy
              Reporter:
              olamy Olivier Lamy
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: