Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54830

Goup mail user are not receiving but shows as recipient list

    Details

    • Similar Issues:

      Description

      For international group mail  recipients are not able to recievw mail but it shows in recipient list.

      somegroup@groups.int.example.com

       

      Creating jobs in Jenkins using .yml file

      for ex:

      • email-ext:
        recipients: priyanga.g@example.com siva-subramaniam.m@example.com thavamani.raja@example.com nithya.ganesan@example.com somegroup@groups.int.example.com smegroup@example.com gavin.brebner@example.com 
        content-type: html

       

      Note: 

      somegroup@example.com==> can able to see the mail

      somegroup@groups.int.example.com==>not able to see

         

        Attachments

          Activity

          priyat Priyanga G created issue -
          priyat Priyanga G made changes -
          Field Original Value New Value
          Description For international group mail  recipients are not able to recievw mail but it shows in recipient list.

          somegroup@groups.int.example.com
          For international group mail  recipients are not able to recievw mail but it shows in recipient list.

          [somegroup@groups.int.example.com|mailto:somegroup@groups.int.example.com]

           

          Creating joobs in jenkins using .yml file
          priyat Priyanga G made changes -
          Labels email-ext
          priyat Priyanga G made changes -
          Description For international group mail  recipients are not able to recievw mail but it shows in recipient list.

          [somegroup@groups.int.example.com|mailto:somegroup@groups.int.example.com]

           

          Creating joobs in jenkins using .yml file
          For international group mail  recipients are not able to recievw mail but it shows in recipient list.

          [somegroup@groups.int.example.com|mailto:somegroup@groups.int.example.com]

           

          Creating jobs in Jenkins using .yml file

          for ex:

          - email-ext:
           recipients: [priyanga.g@example.com|mailto:priyanga.g@example.comsiva-subramaniam.m@example.com thavamani.raja@example.com nithya.ganesan@example.com [somegroup|mailto:somegroup@groups.int.example.com]@groups.int.example.com smegroup@example.com gavin.brebner@example.com 
           content-type: html

           

          Note: 

          somegroup@example.com==> can able to see the mail

          [somegroup@groups.int.example.com|mailto:somegroup@groups.int.example.com]==>not able to see

             
          davidvanlaatum David van Laatum added a comment -

          From jenkins point of view there is no difference between a user email and a group email so if only some emails get through its your mail server

          This is usually caused by mail being hosted on exchange and the email group has only allow authenticated users ticked (which is the default)
           

          davidvanlaatum David van Laatum made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]

            People

            • Assignee:
              davidvanlaatum David van Laatum
              Reporter:
              priyat Priyanga G
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: