Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54843

Maven Enforcer Plugin crashes with java.level=11

    Details

    • Similar Issues:
    • Released As:
      plugin-pom:3.29

      Description

       

      When I want to enforce Java level 11 in a Jenkins plugin, maven Enforcer crashes on requireBytecodeVersion

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M2:enforce (display-info) on project label-verifier: Execution display-info of goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M2:enforce failed: Unknown JDK version given. Should be something like "1.7" -> [Help 1]
      [ERROR]
      

       

      https://github.com/mojohaus/extra-enforcer-rules/pull/63/files is needed to be upstreamed.

      CC Baptiste Mathus

       

        Attachments

          Issue Links

            Activity

            Hide
            batmat Baptiste Mathus added a comment -

            Still needs a release, but fixed through https://github.com/jenkinsci/plugin-pom/pull/136

            Show
            batmat Baptiste Mathus added a comment - Still needs a release, but fixed through https://github.com/jenkinsci/plugin-pom/pull/136
            Hide
            batmat Baptiste Mathus added a comment -

            Actually already released in plugin-pom:3.29

            Show
            batmat Baptiste Mathus added a comment - Actually already released in plugin-pom:3.29

              People

              • Assignee:
                batmat Baptiste Mathus
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: