Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54884

ssh-slaves or trilead-api stops all git over ssh (git+ssh) from working

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.138.3
      ssh-slaves 1.29.1
      trillead-api 1.01 (? dunno; erased)
    • Similar Issues:
    • Released As:
      ssh-slaves-1.29.2

      Description

      With those two plugins installed, all git+ssh stopped working, even if it had nothing to do with slave nodes.

       > git fetch --tags --progress ssh://git@git:7999/proj/jenkins-backups.git +refs/heads/*:refs/remotes/origin/*
      ERROR: Error fetching remote repo 'origin'
      hudson.plugins.git.GitException: Failed to fetch from ssh://git@git:7999/proj/jenkins-backups.git
      	at hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:888)
      	at hudson.plugins.git.GitSCM.retrieveChanges(GitSCM.java:1155)
      	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1186)
      	at hudson.scm.SCM.checkout(SCM.java:504)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1208)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:574)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:499)
      	at hudson.model.Run.execute(Run.java:1819)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:429)
      Caused by: hudson.plugins.git.GitException: Command "git fetch --tags --progress ssh://git@git:7999/proj/jenkins-backups.git +refs/heads/*:refs/remotes/origin/*" returned status code 128:
      stdout: 
      stderr: Permission denied (publickey).
      fatal: Could not read from remote repository.Please make sure you have the correct access rights
      and the repository exists.	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:2016)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1735)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.access$300(CliGitAPIImpl.java:72)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$1.execute(CliGitAPIImpl.java:420)
      	at hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:886)
      	... 11 more
      ERROR: Error fetching remote repo 'origin'
       

      This would happen when pipeline branches were checked as well:

      Started by timer
      [Tue Nov 27 06:36:00 EST 2018] Starting branch indexing...
       > git --version # timeout=10
      using GIT_SSH to set credentials 
       > git ls-remote ssh://git@git:7999/proj/opencpi.git # timeout=10
      ERROR: [Tue Nov 27 06:36:00 EST 2018] Could not update folder level actions from source e9d3dadd-64f7-458c-b3ba-98edd9652a8c
      hudson.plugins.git.GitException: Command "git ls-remote ssh://git@git:7999/proj/opencpi.git" returned status code 128:
      stdout: 
      stderr: Permission denied (publickey).
      fatal: Could not read from remote repository.
      
      Please make sure you have the correct access rights
      and the repository exists.
      
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:2016)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1735)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1640)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1631)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getRemoteReferences(CliGitAPIImpl.java:2851)
      	at jenkins.plugins.git.AbstractGitSCMSource.retrieveActions(AbstractGitSCMSource.java:1113)
      	at jenkins.scm.api.SCMSource.fetchActions(SCMSource.java:765)
      	at jenkins.branch.MultiBranchProject.computeChildren(MultiBranchProject.java:591)
      	at com.cloudbees.hudson.plugins.folder.computed.ComputedFolder.updateChildren(ComputedFolder.java:277)
      	at com.cloudbees.hudson.plugins.folder.computed.FolderComputation.run(FolderComputation.java:165)
      	at jenkins.branch.MultiBranchProject$BranchIndexing.run(MultiBranchProject.java:1025)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:429)
      [Tue Nov 27 06:36:00 EST 2018] Finished branch indexing. Indexing took 0.16 sec
      FATAL: Failed to recompute children of Job_1
      hudson.plugins.git.GitException: Command "git ls-remote ssh://git@git:7999/proj/opencpi.git" returned status code 128:
      stdout: 
      stderr: Permission denied (publickey).
      fatal: Could not read from remote repository.
      
      Please make sure you have the correct access rights
      and the repository exists.
      
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:2016)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1735)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1640)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1631)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getRemoteReferences(CliGitAPIImpl.java:2851)
      	at jenkins.plugins.git.AbstractGitSCMSource.retrieveActions(AbstractGitSCMSource.java:1113)
      	at jenkins.scm.api.SCMSource.fetchActions(SCMSource.java:765)
      	at jenkins.branch.MultiBranchProject.computeChildren(MultiBranchProject.java:591)
      	at com.cloudbees.hudson.plugins.folder.computed.ComputedFolder.updateChildren(ComputedFolder.java:277)
      	at com.cloudbees.hudson.plugins.folder.computed.FolderComputation.run(FolderComputation.java:165)
      	at jenkins.branch.MultiBranchProject$BranchIndexing.run(MultiBranchProject.java:1025)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:429)
      Finished: FAILURE
      

      I verified with the server that the "Jenkins" user has permissions normally:

       # From Jenkins Server as user jenkins
      $ ssh -p 7999 git whoami
      opencpi_jenkins
      $ git fetch # works
      # From Jenkins' "Run buildstep before SCM runs"
      $ /bin/sh -xe /tmp/jenkins3916373384688410155.sh
      + ssh -p 7999 git whoami
      opencpi_jenkins
      Success build forhudson.tasks.Shell@18819daa
      

      Reverting to ssh-slaves 1.28.1 (and uninstalling trilead-api) fixed it.

      Last Tuesday, I updated a bunch of plugins as a batch and couldn't even get a page to render. Since I was only at work for a few hours, I simply rolled back all plugins and let it be. Just mentioning that because I see other tickets that indicate these plugins may have been the problem then as well.

        Attachments

          Issue Links

            Activity

            aarondmarasco_vsi Aaron D. Marasco added a comment -

            If it matters, all plugins:

            JavaScript GUI Lib: ACE Editor bundle plugin (ace-editor): 1.1
            All changes plugin (all-changes): 1.5
            Static Analysis Utilities (analysis-core): 1.95
            Ant Plugin (ant): 1.9
            OWASP Markup Formatter Plugin (antisamy-markup-formatter): 1.5
            Apache HttpComponents Client 4.x API Plugin (apache-httpcomponents-client-4-api): 4.5.5-3.0
            Authentication Tokens API Plugin (authentication-tokens): 1.3
            Basic Branch Build Strategies Plugin (basic-branch-build-strategies): 1.1.1
            Blue Ocean (blueocean): 1.9.0
            Autofavorite for Blue Ocean (blueocean-autofavorite): 1.2.2
            Bitbucket Pipeline for Blue Ocean (blueocean-bitbucket-pipeline): 1.9.0
            Common API for Blue Ocean (blueocean-commons): 1.9.0
            Config API for Blue Ocean (blueocean-config): 1.9.0
            Blue Ocean Core JS (blueocean-core-js): 1.9.0
            Dashboard for Blue Ocean (blueocean-dashboard): 1.9.0
            Display URL for Blue Ocean (blueocean-display-url): 2.2.0
            Events API for Blue Ocean (blueocean-events): 1.9.0
            Git Pipeline for Blue Ocean (blueocean-git-pipeline): 1.9.0
            GitHub Pipeline for Blue Ocean (blueocean-github-pipeline): 1.9.0
            i18n for Blue Ocean (blueocean-i18n): 1.9.0
            JIRA Integration for Blue Ocean (blueocean-jira): 1.9.0
            JWT for Blue Ocean (blueocean-jwt): 1.9.0
            Personalization for Blue Ocean (blueocean-personalization): 1.9.0
            Pipeline implementation for Blue Ocean (blueocean-pipeline-api-impl): 1.9.0
            Blue Ocean Pipeline Editor (blueocean-pipeline-editor): 1.9.0
            Pipeline SCM API for Blue Ocean (blueocean-pipeline-scm-api): 1.9.0
            REST API for Blue Ocean (blueocean-rest): 1.9.0
            REST Implementation for Blue Ocean (blueocean-rest-impl): 1.9.0
            Web for Blue Ocean (blueocean-web): 1.9.0
            bouncycastle API Plugin (bouncycastle-api): 2.17
            Branch API Plugin (branch-api): 2.1.1
            Build Alias Setter Plugin (build-alias-setter): 0.4
            Build Environment Plugin (build-environment): 1.6
            Build Flow plugin (build-flow-plugin): 0.20
            Build Timeout (build-timeout): 1.19
            user build vars plugin (build-user-vars-plugin): 1.5
            Build Trigger Badge Plugin (buildtriggerbadge): 2.9
            built-on-column (built-on-column): 1.1
            Clone Workspace SCM Plug-in (clone-workspace-scm): 0.6
            Bitbucket Branch Source Plugin (cloudbees-bitbucket-branch-source): 2.2.15
            Folders Plugin (cloudbees-folder): 6.7
            Command Agent Launcher Plugin (command-launcher): 1.2
            Conditional BuildStep (conditional-buildstep): 1.3.6
            Config File Provider Plugin (config-file-provider): 3.4.1
            Console Tail Plugin (console-tail): 1.1
            Copy Artifact Plugin (copyartifact): 1.41
            Credentials Plugin (credentials): 2.1.18
            Credentials Binding Plugin (credentials-binding): 1.17
            CVS Plug-in (cvs): 2.14
            Dashboard View (dashboard-view): 2.10
            Delivery Pipeline Plugin (delivery-pipeline-plugin): 1.3.1
            description setter plugin (description-setter): 1.10
            disk-usage plugin (disk-usage): 0.28
            Display URL API (display-url-api): 2.3.0
            Docker Commons Plugin (docker-commons): 1.13
            Docker Pipeline (docker-workflow): 1.17
            Durable Task Plugin (durable-task): 1.28
            Email Extension Plugin (email-ext): 2.63
            Environment Injector Plugin (envinject): 2.1.6
            EnvInject API Plugin (envinject-api): 1.5
            Environment Script Plugin (environment-script): 1.2.5
            Extended Choice Parameter Plug-In (extended-choice-parameter): 0.76
            External Monitor Job Type Plugin (external-monitor-job): 1.7
            Extra Columns Plugin (extra-columns): 1.20
            Fail The Build Plugin (fail-the-build-plugin): 1.0
            Favorite (favorite): 2.3.2
            Flexible Publish Plugin (flexible-publish): 0.15.2
            Git plugin (git): 3.9.1
            Git client plugin (git-client): 2.7.4
            git-notes Plugin (git-notes): 0.0.4
            Git Parameter Plug-In (git-parameter): 0.9.6
            GIT server Plugin (git-server): 1.7
            Git Tag Message Plugin (git-tag-message): 1.6.1
            GitHub plugin (github): 1.29.3
            GitHub API Plugin (github-api): 1.92
            GitHub Branch Source Plugin (github-branch-source): 2.4.1
            GitHub Organization Folder Plugin (github-organization-folder): 1.6
            Green Balls (greenballs): 1.15
            Groovy Label Assignment plugin (groovy-label-assignment): 1.2.0
            JavaScript GUI Lib: Handlebars bundle plugin (handlebars): 1.1.1
            Handy Uri Templates 2.x API Plugin (handy-uri-templates-2-api): 2.1.6-1.0
            HTML Publisher plugin (htmlpublisher): 1.17
            HTTP Request Plugin (http_request): 1.8.22
            Icon Shim Plugin (icon-shim): 2.0.3
            Ivy Plugin (ivy): 1.28
            Jackson 2 API Plugin (jackson2-api): 2.9.7.1
            Javadoc Plugin (javadoc): 1.4
            JDK Tool Plugin (jdk-tool): 1.1
            Design Language (jenkins-design-language): 1.9.0
            JIRA plugin (jira): 3.0.5
            Job DSL (job-dsl): 1.70
            Job Configuration History Plugin (jobConfigHistory): 2.18.3
            jQuery plugin (jquery): 1.12.4-0
            JavaScript GUI Lib: jQuery bundles (jQuery and jQuery UI) plugin (jquery-detached): 1.2.1
            JSch dependency plugin (jsch): 0.1.54.2
            JUnit Plugin (junit): 1.26.1
            LDAP Plugin (ldap): 1.20
            Lockable Resources plugin (lockable-resources): 2.3
            Mailer Plugin (mailer): 1.22
            MapDB API Plugin (mapdb-api): 1.0.9.0
            Matrix Authorization Strategy Plugin (matrix-auth): 2.3
            Matrix Configuration Parameter Plugin (matrix-combinations-parameter): 1.3.0
            Matrix Project Plugin (matrix-project): 1.13
            Maven Integration plugin (maven-plugin): 3.1.2
            Mercurial plugin (mercurial): 2.4
            Metrics Plugin (metrics): 4.0.2.2
            JavaScript GUI Lib: Moment.js bundle plugin (momentjs): 1.1.1
            Multi-Branch Project Plugin (DEPRECATED) (multi-branch-project-plugin): 0.7
            Node and Label parameter plugin (nodelabelparameter): 1.7.2
            Notification plugin (notification): 1.13
            PAM Authentication plugin (pam-auth): 1.4
            Parameterized Trigger plugin (parameterized-trigger): 2.35.2
            PegDown Formatter Plugin (pegdown-formatter): 1.3
            Pipeline: Build Step (pipeline-build-step): 2.7
            Pipeline: GitHub Groovy Libraries (pipeline-github-lib): 1.0
            Pipeline Graph Analysis Plugin (pipeline-graph-analysis): 1.9
            Pipeline: Input Step (pipeline-input-step): 2.8
            Pipeline: Milestone Step (pipeline-milestone-step): 1.3.1
            Pipeline: Model API (pipeline-model-api): 1.3.2
            Pipeline: Declarative Agent API (pipeline-model-declarative-agent): 1.1.1
            Pipeline: Declarative (pipeline-model-definition): 1.3.2
            Pipeline: Declarative Extension Points API (pipeline-model-extensions): 1.3.2
            Pipeline: REST API Plugin (pipeline-rest-api): 2.10
            Pipeline: Stage Step (pipeline-stage-step): 2.3
            Pipeline: Stage Tags Metadata (pipeline-stage-tags-metadata): 1.3.2
            Pipeline: Stage View Plugin (pipeline-stage-view): 2.10
            Pipeline Utility Steps (pipeline-utility-steps): 2.2.0
            Plain Credentials Plugin (plain-credentials): 1.4
            PostBuildScript Plugin (postbuildscript): 2.8.1
            Pre SCM BuildStep Plugin (preSCMbuildstep): 0.3
            Pub-Sub "light" Bus (pubsub-light): 1.12
            ruby-runtime (ruby-runtime): 0.13
            Run Condition Plugin (run-condition): 1.2
            Run Selector Plugin (run-selector): 1.0.0
            SCM API Plugin (scm-api): 2.3.0
            Script Security Plugin (script-security): 1.48
            Show Build Parameters plugin (show-build-parameters): 1.0
            Server Sent Events (SSE) Gateway Plugin (sse-gateway): 1.16
            SSH Credentials Plugin (ssh-credentials): 1.14
            SSH Slaves plugin (ssh-slaves): 1.28.1
            Status Monitor Plugin (statusmonitor): 1.3
            Structs Plugin (structs): 1.17
            Subversion Plug-in (subversion): 2.12.1
            Support Core Plugin (support-core): 2.51
            Task Scanner Plug-in (tasks): 4.52
            ThinBackup (thinBackup): 1.9
            Throttle Concurrent Builds Plug-in (throttle-concurrents): 2.0.1
            Timestamper (timestamper): 1.8.10
            java.io.tmpdir cleaner plugin (tmpcleaner): 1.3
            Token Macro Plugin (token-macro): 2.5
            Tool Labels Plugin for Jenkins (tool-labels-plugin): 3.0
            Translation Assistance plugin (translation): 1.16
            Uptime (uptime): 1.0
            Valgrind Plug-in (valgrind): 0.28
            Variant Plugin (variant): 1.1
            Warnings Plug-in (warnings): 4.68
            Windows Slaves Plugin (windows-slaves): 1.3.1
            Pipeline (workflow-aggregator): 2.6
            Pipeline: API (workflow-api): 2.33
            Pipeline: Basic Steps (workflow-basic-steps): 2.12
            Pipeline: Groovy (workflow-cps): 2.60
            Pipeline: Shared Groovy Libraries (workflow-cps-global-lib): 2.12
            Pipeline: Nodes and Processes (workflow-durable-task-step): 2.26
            Pipeline: Job (workflow-job): 2.29
            Pipeline: Multibranch (workflow-multibranch): 2.20
            Pipeline: SCM Step (workflow-scm-step): 2.7
            Pipeline: Step API (workflow-step-api): 2.16
            Pipeline: Supporting APIs (workflow-support): 2.22
            ifernandezcalvo Ivan Fernandez Calvo added a comment -

            Aaron D. Marasco
            Weird, I have tested it on Jenkins core 2.152 with ssh-slaves 1.29.1 to access to a git private repo with a 4096 bits RSA key, I will test it on 2.138.3, Could you give me some info about your SSH key? Which are the length and algorithm? Has it passphrase? Is your Jenkins instance running on windows?

            aarondmarasco_vsi Aaron D. Marasco added a comment -

            CentOS 7 running the LTS version of Jenkins. All other plugins are up-to-date. The git server is BitBucket. Shouldn't matter, but it might.

            $ sudo -u jenkins openssl rsa -text -noout -in ~jenkins/.ssh/id_rsa | grep bit
            Private-Key: (2048 bit)
            

            No passphrase.

            $ sudo grep -v '^#' /etc/sysconfig/jenkins | grep -v '^$'
            JENKINS_HOME="/var/lib/jenkins"
            JENKINS_JAVA_CMD=""
            JENKINS_USER="jenkins"
            JENKINS_JAVA_OPTIONS="-Djava.awt.headless=true -Dhudson.model.ParametersAction.keepUndefinedParameters=true -Dorg.jenkinsci.plugins.docker.workflow.client.DockerClient.CLIENT_TIMEOUT=60 -Dorg.jenkinsci.plugins.durabletask.BourneShellScript.HEARTBEAT_CHECK_INTERVAL=400"
            JENKINS_PORT="-1"
            JENKINS_LISTEN_ADDRESS=""
            JENKINS_HTTPS_PORT="8080"
            JENKINS_HTTPS_KEYSTORE=""
            JENKINS_HTTPS_KEYSTORE_PASSWORD=""
            JENKINS_HTTPS_LISTEN_ADDRESS=""
            JENKINS_AJP_PORT="8009"
            JENKINS_AJP_LISTEN_ADDRESS=""
            JENKINS_DEBUG_LEVEL="5"
            JENKINS_ENABLE_ACCESS_LOG="no"
            JENKINS_HANDLER_MAX="100"
            JENKINS_HANDLER_IDLE="20"
            JENKINS_ARGS=""
            
            ifernandezcalvo Ivan Fernandez Calvo added a comment - - edited

            I could not replicate the issue but the cause seems clear, so I changed to use Trilead ssh2 from Jenkins Core and use Trilead API plugin only for test, you have to uninstall the Trilead API plugin is not used. it also needs to restart Jenkins

            aarondmarasco_vsi Aaron D. Marasco added a comment - - edited

            Updated all plugins and now have 1.29.4; confirmed everything works now after some changes I needed for JENKINS-54746 - comment. Thanks!


              People

              • Assignee:
                ifernandezcalvo Ivan Fernandez Calvo
                Reporter:
                aarondmarasco_vsi Aaron D. Marasco
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: