Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55182

CasC compatibility with Lockable Resource plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Lockable resource plugin can't be configured via CASC.  It seems due to violation of "Rule 1: don't write code for data-binding" from https://github.com/jenkinsci/configuration-as-code-plugin/blob/master/docs/REQUIREMENTS.md 

      Auto generated documentation (at <jenkins-host>:configuration-as-code/reference) contains mention of 'lockableresourcesmanager' entry and nothing more.

      Configuring it manually and exporting its configuration gave also nothing exported. 

       

        Attachments

          Issue Links

            Activity

            Hide
            uhanisch Uwe Hanisch added a comment -

            PR https://github.com/jenkinsci/lockable-resources-plugin/pull/122 solve it.

            For a good test coverage it would be needed to change the dependencies to Jenkins 2.60
            See https://github.com/jenkinsci/configuration-as-code-plugin/blob/master/docs/REQUIREMENTS.md

            Show
            uhanisch Uwe Hanisch added a comment - PR https://github.com/jenkinsci/lockable-resources-plugin/pull/122 solve it. For a good test coverage it would be needed to change the dependencies to Jenkins 2.60 See https://github.com/jenkinsci/configuration-as-code-plugin/blob/master/docs/REQUIREMENTS.md

              People

              • Assignee:
                Unassigned
                Reporter:
                alexkoi8 Alexander Zobkov
              • Votes:
                3 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: