Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55204

Maven plugin (version 3.1) is not using the libembedder corresponding to the used maven version

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Maven plugin 3.1
      Maven version 3.3.3
      Jenkins version 2.73.32.0.1
    • Similar Issues:

      Description

      It seems the maven plugin (version 3.1) is not using the libembedder corresponding to the used maven version. This makes that when using a maven feature available in the used maven version (wildcard exclusions, in maven 3.3.3), we observe an error.

       

      10:19:59 [WARNING] 'dependencyManagement.dependencies.dependency.exclusions.exclusion.artifactId' for com.xxxxxxxxx:xxxxxxx:jar with value '*' does not match a valid id pattern. @ xxxxxxxxxx:5.0.0-SNAPSHOT, C:\Jenkins\workspace\xxxxx\develop\xxxxx\.repository\com\xxxxxxxx\xxxxxx\enterprise.dependencies\5.0.0-SNAPSHOT\enterprise.dependencies-5.0.0-SNAPSHOT.pom, line 675, column 37 
      10:19:59 
      10:19:59 at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:364) 
      10:19:59 at hudson.maven.MavenEmbedder.buildProjects(MavenEmbedder.java:361) 
      10:19:59 at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:331) 
      10:19:59 at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1328)

        Attachments

          Activity

          jraezrus Javier Raez created issue -
          olamy Olivier Lamy made changes -
          Field Original Value New Value
          Assignee Olivier Lamy [ olamy ]

            People

            • Assignee:
              olamy Olivier Lamy
              Reporter:
              jraezrus Javier Raez
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: