Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: git-client-plugin
    • Labels:
      None
    • Environment:
      3.0.0-beta6
    • Similar Issues:

      Description

      In https://github.com/jenkinsci/kubernetes-plugin/pull/307

      Rolling back to 2.7.5 works

       0.864 [job with dir #1] Cloning the remote Git repository
         0.864 [job with dir #1] Cloning repository /home/jenkins/workspace/kubernetes-plugin_PR-307-SFDGZ2FIBNOJQRX23XODNYZT3BPRZLCHUYDKCTJX3M3JCPPS4NIQ/target/tmp/junit5505933791676957731/junit6408912028318887609
         0.864 [job with dir #1]  > git init /home/jenkins/workspace/kubernetes-plugin_PR-307-SFDGZ2FIBNOJQRX23XODNYZT3BPRZLCHUYDKCTJX3M3JCPPS4NIQ/target/tmp/jkh3020561214249107704/workspace/job with dir@script # timeout=10
         0.864 [job with dir #1] Fetching upstream changes from /home/jenkins/workspace/kubernetes-plugin_PR-307-SFDGZ2FIBNOJQRX23XODNYZT3BPRZLCHUYDKCTJX3M3JCPPS4NIQ/target/tmp/junit5505933791676957731/junit6408912028318887609
         0.864 [job with dir #1]  > git --version # timeout=10
         0.864 [job with dir #1]  > git fetch --tags --progress /home/jenkins/workspace/kubernetes-plugin_PR-307-SFDGZ2FIBNOJQRX23XODNYZT3BPRZLCHUYDKCTJX3M3JCPPS4NIQ/target/tmp/junit5505933791676957731/junit6408912028318887609 +refs/heads/*:refs/remotes/origin/*
         0.914 [job with dir #1]  > git config remote.origin.url /home/jenkins/workspace/kubernetes-plugin_PR-307-SFDGZ2FIBNOJQRX23XODNYZT3BPRZLCHUYDKCTJX3M3JCPPS4NIQ/target/tmp/junit5505933791676957731/junit6408912028318887609 # timeout=10
         0.914 [job with dir #1]  > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
         0.914 [job with dir #1]  > git config remote.origin.url /home/jenkins/workspace/kubernetes-plugin_PR-307-SFDGZ2FIBNOJQRX23XODNYZT3BPRZLCHUYDKCTJX3M3JCPPS4NIQ/target/tmp/junit5505933791676957731/junit6408912028318887609 # timeout=10
         0.914 [job with dir #1] Fetching upstream changes from /home/jenkins/workspace/kubernetes-plugin_PR-307-SFDGZ2FIBNOJQRX23XODNYZT3BPRZLCHUYDKCTJX3M3JCPPS4NIQ/target/tmp/junit5505933791676957731/junit6408912028318887609
         0.914 [job with dir #1]  > git fetch --tags --progress /home/jenkins/workspace/kubernetes-plugin_PR-307-SFDGZ2FIBNOJQRX23XODNYZT3BPRZLCHUYDKCTJX3M3JCPPS4NIQ/target/tmp/junit5505933791676957731/junit6408912028318887609 +refs/heads/*:refs/remotes/origin/*
         0.915 [job with dir #1]  > git rev-parse refs/remotes/origin/master^{commit} # timeout=10
         0.915 [job with dir #1]  > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10
         0.915 [job with dir #1] Checking out Revision 9a3dbba07d0615fb83c651f5c44b59e15a9c99dc (refs/remotes/origin/master)
         0.915 [job with dir #1]  > git config core.sparsecheckout # timeout=10
         0.965 [job with dir #1]  > git checkout -f 9a3dbba07d0615fb83c651f5c44b59e15a9c99dc
         0.965 [job with dir #1]  > git branch -a -v --no-abbrev # timeout=10
         0.965 [job with dir #1]  > git checkout -b master 9a3dbba07d0615fb83c651f5c44b59e15a9c99dc
         0.965 [job with dir #1] Commit message: "files"
         0.965 [job with dir #1] First time build. Skipping changelog.
         0.965 [job with dir #1] Running in Durability level: MAX_SURVIVABILITY
         1.688 [job with dir #1] [Pipeline] readTrusted
       180.001 [id=1]	WARNING	o.j.hudson.test.JenkinsRule$2#evaluate: Test timed out (after 180 seconds).
      

        Attachments

          Activity

          markewaite Mark Waite added a comment - - edited

          I assumed that CloudBees PR builder shows the failure and that CloudBees PR builder on PR 415 shows a narrower change with the same failure, a test timeout in the KubernetesPipelineTest. Unfortunately, that assumption seems to be wrong, since the same KubernetesPipelineTest failures are visible on PR-415 even when all changes have been reverted from PR-415.

          Can you confirm that and provide more details of what you learned while diagnosing that the rollback of git client plugin was the solution to the problem?

          Pull request 307 seems to have previously included git client plugin 3.0.0-beta5. The most recent version is 3.0.0-beta6.

          Pull request 307 includes git plugin plugin 3.9.1. The most recent version is 4.0.0-beta4. While git plugin 3.9.1 should be able to work with git client plugin 3.0.0-beta6, that is not a combination that I actively test.

          I've confirmed that the kubernetes plugin unit tests run successfully with several different combinations of git client 3.0 and git plugin 4.0 beta versions. I assume the issue is not visible from the kubernetes plugin unit tests, but only in an integration test environment.

          markewaite Mark Waite added a comment -

          Resolved by changes in the CI job which were unrelated to the git plugin beta or the git client plugin beta. Thanks for testing with the beta!

          csanchez Carlos Sanchez added a comment -

          For the record this was fixed by upgrading git, scm-api and apache-httpcomponents-client-4-api together with git-client
          https://github.com/jenkinsci/kubernetes-plugin/pull/415/files


            People

            • Assignee:
              markewaite Mark Waite
              Reporter:
              csanchez Carlos Sanchez
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: