Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55435

Issue with performance plugin for performance center test

    Details

    • Similar Issues:

      Description

      Hi, Right now I am using Performance Center 12.6 integrated with Jenkins. I am trying to use this Plug-In to 'Publish Performance test result report' after the test has been done in Performance Center 12.6. I provided the Source Data Files = output.mdb and when the build is done I am not getting the Performance Test Result report and I am seeing the below error in the Console Log: Can anyone please let me know if you use this plug-in in getting performance test result report from Performance Center after the build has been ran.

      I went ahead and checked the workspace and could not find output.mdb file. It is complaining regarding that file is not available. Since this output.mdb file is in the performance center server and did not copied over to Jenkins server after the build test has been done, Is there a way to automatically copy this mdb file into Jenkins after the build test has been done. 

      Recording plot data
      Cannot detect file type because of error: Failed to copy /apps/jenkins/jobs/performanceCenter/jobs/1219_FEPDRET_PERCRTSLA_TREND/workspace/*/output.mdb to /apps/jenkins/jobs/performanceCenter/jobs/1219_FEPDRET_PERCRTSLA_TREND/builds/2/temp/*/output.mdb
      Build step 'Publish Performance test result report' changed build result to FAILURE

        Attachments

          Activity

          Hide
          mahi_fepoc Mahipal Erasani added a comment -

          Hi Phillippe,

          Sorry I was out all these days.

          In the workspace directory, There are bunch of .csv files and .xml files. There is no .mdb file. This seems to be issue .. that the output.mdb file was not getting carried over to Jenkins server workspace directory from the performance center server.

          Thanks

           

          Show
          mahi_fepoc Mahipal Erasani added a comment - Hi Phillippe, Sorry I was out all these days. In the workspace directory, There are bunch of .csv files and .xml files. There is no .mdb file. This seems to be issue .. that the output.mdb file was not getting carried over to Jenkins server workspace directory from the performance center server. Thanks  
          Hide
          pmouawad Philippe Mouawad added a comment -

          Hello,

          So this would not be a bug ?

          Thanks

          Show
          pmouawad Philippe Mouawad added a comment - Hello, So this would not be a bug ? Thanks
          Hide
          mahi_fepoc Mahipal Erasani added a comment -

          Hi,

          I am thinking this plugin should download the .mdb file from the performance center and generate the graphs.

          Do you know how can this be done?

          Thanks

          Show
          mahi_fepoc Mahipal Erasani added a comment - Hi, I am thinking this plugin should download the .mdb file from the performance center and generate the graphs. Do you know how can this be done? Thanks
          Hide
          pmouawad Philippe Mouawad added a comment -

          Why don't you copy this file from LoadRunner to a path accessible to Jenkins ?

          Alternatively , ask your Load Runner support how to get access to MDB file through API, then we could do something.
          Thanks

          Show
          pmouawad Philippe Mouawad added a comment - Why don't you copy this file from LoadRunner to a path accessible to Jenkins ? Alternatively , ask your Load Runner support how to get access to MDB file through API, then we could do something. Thanks
          Hide
          planet Nishan Silva added a comment -

          I have installed 3.17 performance plugin, but performance graphs (Trend Reports) are not displaying. Could you please provide a solution for this?

          OS: MacOS

          Graphs are not displaying 

          Error Message

          Configuration 

           

           

          Show
          planet Nishan Silva added a comment - I have installed 3.17 performance plugin, but performance graphs (Trend Reports) are not displaying . Could you please provide a solution for this? OS: MacOS Graphs are not displaying   Error Message Configuration      

            People

            • Assignee:
              undera Andrey Pokhilko
              Reporter:
              mahi_fepoc Mahipal Erasani
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: