Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55509

"Windows Username" on configure page is replaced on "Build" value while another value was set and saved

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Browsers: Chrome, Safari
      Jenkins ver. 2.107.2
      Google Compute Engine Plugin 1.0.7
    • Similar Issues:

      Description

      Steps to reproduce:

      1. Open http://<your_jenkins_server_address>/configure page
      2. Add new GCE instance and set "Windows?" checkbox
      3. Change "Windows Username" from default value "Build" to "tester" value
      4. Press "Save" button
      5. Goto jenkins server and check value in config.xml:              

        cat $JENKINS_HOME/config.xml | grep "windowsUsername" 
        Output example: <windowsUsername>tester</windowsUsername>

      6. Open http://<your_jenkins_server_address>/configure page again

        Expected: "tester" value in "Windows Username"
        Actual: "Build" value in "Windows Username"

         
        Jenkins log shows exception mentioned in JENKINS-39598 but other parameters works as expected. For example, parameter "Windows SSH Private Key Credentials" saved and configure page shows changed value after reopen. So looks like exception isn't related this bug. 

        Attachments

          Activity

          ingwar Karol Lassak added a comment -

          I can confirm that this bug exists..

           

          Seems that when opening config page it always use Build as value, and if you save config it overwrites previously set value.

          zombiemoose Rachel Yen added a comment -

          Weird, I will test this by getting rid of the default value in the jelly and let's see what happens.

          ingwar Karol Lassak added a comment -

          I just created PR that should fix this issue..

          https://github.com/jenkinsci/google-compute-engine-plugin/pull/34


            People

            • Assignee:
              zombiemoose Rachel Yen
              Reporter:
              verusikk Vera Akulova
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: