Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55562

Plugin can not be loaded anymore due to JDK Problems

    Details

    • Similar Issues:
    • Released As:
      Performance Signature 3.0.3

      Description

      I recently updated the Plugin to Version 3.0.2 - Now I get the following Error after my Jenkins Restart:

      Performance Signature: UI version 3.0.2
      You must update Java from version 1.8 to version 8 or later to run this plugin.

      Switching back to 3.0.1 solves this problem

      Jenkins ver. 2.158.
      JDK: 1.8.0_181-b13

        Attachments

          Issue Links

            Activity

            forster_ch Christoph Forster created issue -
            forster_ch Christoph Forster made changes -
            Field Original Value New Value
            Description I recently updated the Plugin to Version 3.0.2 - Now I get the following Error after my Jenkins Restart:

            Performance Signature: UI version 3.0.2
            You must update Java from version 1.8 to version 8 or later to run this plugin.
            I recently updated the Plugin to Version 3.0.2 - Now I get the following Error after my Jenkins Restart:

            Performance Signature: UI version 3.0.2
            You must update Java from version 1.8 to version 8 or later to run this plugin.

            Switching back to 3.0.1 solves this problem
            oleg_nenashev Oleg Nenashev added a comment -

            In https://github.com/jenkinsci/performance-signature-dynatrace-plugin/commit/8a1b6d306caac6148c103e90a2e690a9f26af61d  the pom.xml was updated to 3.30+. It included the minimum Java version requirement.

             

            I believe the latest Jenkins weekly with https://github.com/jenkinsci/jenkins/pull/3016 is used, CC Baptiste Mathus. The version comparison does not cover the case, and hence it blows up

            oleg_nenashev Oleg Nenashev made changes -
            Component/s core [ 15593 ]
            Component/s performance-signature-dynatrace-plugin [ 21420 ]
            oleg_nenashev Oleg Nenashev made changes -
            Labels regression
            oleg_nenashev Oleg Nenashev made changes -
            Priority Critical [ 2 ] Blocker [ 1 ]
            oleg_nenashev Oleg Nenashev made changes -
            Epic Link JENKINS-51805 [ 191255 ]
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Raphael Pionke [ rpionke ]
            batmat Baptiste Mathus added a comment -

            Christoph Forster what is your Jenkins version please? Also what is the JVM version you're running Jenkins on? Answering all these will you and anyone fixing possible issues quicker

            oleg_nenashev Oleg Nenashev added a comment -

            The message comes from 2.158 (it is in https://github.com/jenkinsci/jenkins/pull/3016 ). So I believe Christoph Forster is on the latest weekly.

            Apart from Dynatrace plugin, there are "mailer" and "workflow-cps" plugins using the latest Plugin POM. It is enough to screw almost every instance if it happens on any JVM

             

            wreggyl Jan Bottek made changes -
            Assignee Jan Bottek [ wreggyl ]
            forster_ch Christoph Forster added a comment -

            Hi, Yes I run on Jenkins ver. 2.158.
            JDK: 1.8.0_181-b13

            forster_ch Christoph Forster made changes -
            Description I recently updated the Plugin to Version 3.0.2 - Now I get the following Error after my Jenkins Restart:

            Performance Signature: UI version 3.0.2
            You must update Java from version 1.8 to version 8 or later to run this plugin.

            Switching back to 3.0.1 solves this problem
            I recently updated the Plugin to Version 3.0.2 - Now I get the following Error after my Jenkins Restart:

            Performance Signature: UI version 3.0.2
            You must update Java from version 1.8 to version 8 or later to run this plugin.

            Switching back to 3.0.1 solves this problem

            Jenkins ver. 2.158.
            JDK: 1.8.0_181-b13
            wreggyl Jan Bottek made changes -
            Assignee Jan Bottek [ wreggyl ]
            oleg_nenashev Oleg Nenashev added a comment -

            JENKINS-55575 would be the best way to offer proper version comparison in the Jenkins core.

            I tested the logic manually, and I cannot reproduce it with Mailer plugin and with Pipeline: CPS. Likely there is something with dependency check flags and the generated manifest data, checking

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue relates to JENKINS-55575 [ JENKINS-55575 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Soo, it comes from https://github.com/jenkinsci/performance-signature-dynatrace-plugin/blob/master/pom.xml#L97 . "minimumJavaVersion=8" is explicitly defined in the plugin.

             

            I consider it as not-a-blocker then, because the default behavior of Plugin POM won't break. We still need to apply fixes in the core though

            oleg_nenashev Oleg Nenashev made changes -
            Priority Blocker [ 1 ] Critical [ 2 ]
            oleg_nenashev Oleg Nenashev made changes -
            Labels regression java11 regression
            oleg_nenashev Oleg Nenashev added a comment -

            I have created https://github.com/jenkinsci/performance-signature-dynatrace-plugin/pull/5 with a workaround in the plugin. A fix on the core side is still needed IMHO

            batmat Baptiste Mathus made changes -
            Labels java11 regression java11 regression triaged
            jglick Jesse Glick made changes -
            Component/s performance-signature-dynatrace-plugin [ 21420 ]
            Component/s core [ 15593 ]
            oleg_nenashev Oleg Nenashev made changes -
            Component/s core [ 15593 ]
            Component/s performance-signature-dynatrace-plugin [ 21420 ]
            jglick Jesse Glick made changes -
            Remote Link This issue links to "PR 6 (Web Link)" [ 22204 ]
            jglick Jesse Glick made changes -
            Assignee Jesse Glick [ jglick ]
            jglick Jesse Glick made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jglick Jesse Glick made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            jglick Jesse Glick added a comment -

            From my PoV this is simply a bug in the plugin and no change in core is needed.

            jglick Jesse Glick added a comment -

            I intentionally changed the component from core to the plugin, as described above.

            jglick Jesse Glick made changes -
            Component/s performance-signature-dynatrace-plugin [ 21420 ]
            Component/s core [ 15593 ]
            oleg_nenashev Oleg Nenashev added a comment -

            There was also a change in Maven HPI Plugin and Plugin POM. Starting from Plugin POM 3.33, it is possible to just set a "hpi.compatibleSinceVersion" property so that there is no need to override values anymore

            jglick Jesse Glick made changes -
            Status In Review [ 10005 ] In Progress [ 3 ]
            jglick Jesse Glick made changes -
            Status In Progress [ 3 ] Open [ 1 ]
            jglick Jesse Glick made changes -
            Assignee Jesse Glick [ jglick ] Raphael Pionke [ rpionke ]
            jglick Jesse Glick made changes -
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            Resolution Fixed [ 1 ]
            rpionke Raphael Pionke made changes -
            Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]
            Released As Performance Signature 3.0.3
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue relates to JENKINS-55980 [ JENKINS-55980 ]

              People

              • Assignee:
                rpionke Raphael Pionke
                Reporter:
                forster_ch Christoph Forster
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: