Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55629

Bitbucket source missing after upgrade to 2.4.0

    Details

    • Similar Issues:

      Description

      Jenkins Version: 2.7.4

      Bitbucket Branch Source Plugin Version: 2.4.0

      Bitbucket Branch Source Plugin previous Version: 1.8

       

      Missing Option: "Bitbucket" in "Multibranch Pipeline -> Branch Sources"

      Doesn't give me an option to specify Repository.
      Couldn't proceed any further.

        Attachments

        1. missing-Source.png
          missing-Source.png
          10 kB
        2. screenshot-1.png
          screenshot-1.png
          55 kB
        3. screenshot-2.png
          screenshot-2.png
          207 kB
        4. screenshot-3.png
          screenshot-3.png
          186 kB

          Activity

          kvijay460 Vijay K created issue -
          kvijay460 Vijay K made changes -
          Field Original Value New Value
          Attachment missing-Source.png [ 45736 ]
          kvijay460 Vijay K made changes -
          Description Jenkins Version: 2.7.4

          Bitbucket Branch Source Plugin Version: 2.4.0

          Bitbucket Branch Source Plugin previous Version: 1.8

           

          Missing Option: "Bitbucket" in "Multibranch Pipeline -> Branch Sources"
          Couldn't proceed any further.
          Jenkins Version: 2.7.4

          Bitbucket Branch Source Plugin Version: 2.4.0

          Bitbucket Branch Source Plugin previous Version: 1.8

           

          Missing Option: "Bitbucket" in "Multibranch Pipeline -> Branch Sources"

          Doesn't give me an option to specify Repository.
           Couldn't proceed any further.
          vivek Vivek Pandey made changes -
          Labels jenkins plugin jenkins pipeline-triaged plugin
          vivek Vivek Pandey made changes -
          Attachment screenshot-1.png [ 45743 ]
          vivek Vivek Pandey added a comment -

          Vijay K Can't reproduce. I tried latest Jenkins 2.150.2 with bitbucket-branch-source 2.4.0 and bitbucket 1.8, I can see Bitbucket in the drop down and it can be configured just fine. Can you check if you have these plugins installed and loaded correctly? Also, any error during jenkins startup?

          vivek Vivek Pandey made changes -
          Priority Blocker [ 1 ] Minor [ 4 ]
          kshultz Karl Shultz made changes -
          Attachment screenshot-2.png [ 45755 ]
          kshultz Karl Shultz made changes -
          Attachment screenshot-3.png [ 45756 ]
          kshultz Karl Shultz added a comment -

          Vijay K - thanks for filing this

          I noticed that you've mentioned running "Jenkins 2.7.4." Is that correct? Because, if so, I bet that's why stuff isn't working for you. I took a look at the plugin's pom.xml file, and it specifies a minimum Jenkins version of 2.60.3, here, on L54.

          Are you able to move to a more up to date version of Jenkins itself? I'd recommend doing so anyway. Lots and lots of enhancements have gone in since 2.7.4, including a whole bunch of security enhancements that would be good to pick up.

          In any event, I can't recreate it either.

          Here it is running locally on my laptop, by building the plugin at the cloudbees-bitbucket-branch-source-2.4.0 tag, and running it in development mode via mvn hpi:run. That ends me up with Jenkins core 2.60.3:

          I've also installed it to my more traditional system, which is running core 2.160 along with various beta-level plugins from the experimental update center:

          kvijay460 Vijay K added a comment -

          Thanks a lot for your Feedback here. I'll plan to upgrade Jenkins and check if things work fine.

          Closing the issue in regards to your suggestions.

          kvijay460 Vijay K made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Karl Shultz [ kshultz ]
          Resolution Cannot Reproduce [ 5 ]

            People

            • Assignee:
              kshultz Karl Shultz
              Reporter:
              kvijay460 Vijay K
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: