Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55645

SCP Plugin: Algorithm negotiation fail fix

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: scp-plugin
    • Labels:
    • Environment:
      Ubuntu Linux
      OpenSSH_7.2p2 Ubuntu-4ubuntu2.6, OpenSSL 1.0.2g 1 Mar 2016
    • Similar Issues:

      Description

      Hi. I just fix Algorithm negotiation fail. Scp plugin does not work at new OpenSSH:

      ERROR: Failed to upload files
      com.jcraft.jsch.JSchException: Algorithm negotiation fail
          at com.jcraft.jsch.Session.receive_kexinit(Session.java:520)
          at com.jcraft.jsch.Session.connect(Session.java:286)
          at com.jcraft.jsch.Session.connect(Session.java:150)
          at be.certipost.hudson.plugin.SCPSite.createSession(SCPSite.java:153)
          at be.certipost.hudson.plugin.SCPRepositoryPublisher.perform(SCPRepositoryPublisher.java:160)
          at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
          at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
          at hudson.model.Build$BuildExecution.post2(Build.java:185)
          at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665)
          at hudson.model.Run.execute(Run.java:1745)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:404)
      Build step 'Publish artifacts to SCP Repository' changed build result to UNSTABLE
      
      

      To fix this problem you need upgrade jsch library (i use 0.1.55). Put this jar to jenkins/plugins/scp/WEB-INF/lib/. Edit pom.xml from jenkins/plugins/scp/META-INF/maven/org.jvnet.hudson.plugins/scp/ and change version string to 0.1.55:

      <dependencies>
              <dependency>
                  <groupId>com.jcraft</groupId>
                  <artifactId>jsch</artifactId>
                  <version>0.1.55</version>
              </dependency>
          </dependencies>
      

      Please update jsch lib to the lastest version. Thanks!

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              andresrc Andres Rodriguez
              Reporter:
              gremlin_tomsk Ivan Podporin
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: