Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5587

When build finishes with failure ("Finished: FAILURE"), report which plugins and/or core components have contributed to the failure

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
      None
    • Environment:
      Hudson ver. 1.345, standalone (run with java -jar hudson.war) on Linux i386

      Description

      Currently I have two builds which go fine until they end with the message "Finished: FAILURE" for no apparent reason.

      There are no fatal exceptions nor any errors ("[ERROR]") logged in their output, yet they register red and at the end of build logs I always see:

      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESSFUL
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 21 minutes 47 seconds
      [INFO] Finished at: Tue Feb 09 18:39:19 CET 2010
      [INFO] Final Memory: 74M/392M
      [INFO] ------------------------------------------------------------------------
      channel stopped
      [ANALYSIS-COLLECTOR] Found 36 annotations (0 new, 9 high, 27 normal, 0 low)
      [ANALYSIS-COLLECTOR] Not changing build status, since no threshold has been exceeded
      Publishing Cobertura coverage report...
      No coverage results were found using the pattern '**/target/site/cobertura/coverage.xml' relative to '/opt/hudson/.hudson/jobs/wdx/workspace/wdx'. Did you enter a pattern relative to the correct directory? Did you generate the XML report(s) for Cobertura?
      Sending e-mails to: Aleksander.Adamowski@firstdata.pl
      Finished: FAILURE

      I suspect that the problem lies with the analysis collector or Cobertura plugin. However, this is not the scope of this bug report.

      The purpose of this report is that, in my opinion, the final "Finished" message should output a list of all the plugins and components whose return statuses have triggered changins the overall build status to failure.

      This way the user can immediately identify the cause of the issue instead of sifting through the build log looking for exceptions and error messages which might not be there, or if they are there, they may bear no significance.

        Activity

        olo olo added a comment -

        This should also relate to the ABORTED status - see JENKINS-4345.

        The importance of this issue is signified by bogus bug reports caused by misidentified failure causes - see e.g. JENKINS-5258.

        danielbeck Daniel Beck added a comment -

        Build logs contain numerous statements regarding which build step failed a build in recent Jenkins versions. How can this problem be reproduced? Why is it considered a core issue?


          People

          • Assignee:
            Unassigned
            Reporter:
            olo olo
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: