Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-55980

Make Jenkins tolerant against incorrect minimum Java version specifications in plugin metadata

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Similar Issues:
    • Released As:
      2.164

      Description

      This is a follow-up to JENKINS-55562.

       

      Once JENKINS-55575 is integrated into Lib Version Number, we can use new generic classes for robust Java version comparison in the core. It should prevent issues if any other plugin ships something unexpected in the metadata (like "8" instead of "1.8")

        Attachments

          Issue Links

            Activity

            There are no comments yet on this issue.

              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: