Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56028

StackOverflowError after workflow-support upgrade

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Jenkins 2.16, Pipeline Support APIs 3.2
    • Similar Issues:

      Description

      After upgrading the workflow support APIs plugin to version 3.0 or version 3.2 our pipeline does not work any more. The problem is not about pipelines running during the upgrade as mentioned in the plugin changelog but with all runs.

      How to reproduce

      1. Update to workflow support plugin version >= 3.0
      2. Run a build with our Jenkinsfile (I attached a file removing all parts I think are not relevant)

      Expected behavior

      Pipeline works as before the update

      Actual behavior

      Pipeline works in the beginning but then exits with a StackOverflowError:

      [Pipeline] {
      [Pipeline] End of Pipelinejava.lang.StackOverflowError
       at org.jboss.marshalling.river.RiverMarshaller.doWriteObject(RiverMarshaller.java:114)
       at org.jboss.marshalling.river.RiverMarshaller.doWriteFields(RiverMarshaller.java:1082)
       at org.jboss.marshalling.river.RiverMarshaller.doWriteSerializableObject(RiverMarshaller.java:1040)
       at org.jboss.marshalling.river.RiverMarshaller.doWriteSerializableObject(RiverMarshaller.java:1019)
       at org.jboss.marshalling.river.RiverMarshaller.doWriteObject(RiverMarshaller.java:920)

      The job ends but still occupies the agent slot.

      Additional information

      • We are using Multibranch Pipeline to automatically build all our branches
      • Downgrading the plugin helped last time but does not work any more as now other plugins depend on the new version.
      • It appears that the error occurs at the same time. However, since this is a parallel stage I am not sure if it is during mvn install or during the frontend installation
      • There is an option retry(3) right before the problem. This is the next thing I will check.

       

        Attachments

          Issue Links

            Activity

            dnusbaum Devin Nusbaum added a comment -

            Perhaps something in the 2.x line of JBoss marshalling makes this happen more often? The same issue was reported as early as August 2018 in JENKINS-52966, so I am going to close this as a dupe of that issue.


              People

              • Assignee:
                dnusbaum Devin Nusbaum
                Reporter:
                stielerit Michael Cornel
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: