Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56138

PCT Docker image should support taking plugin versions from WEB-INF/plugins instead of localCheckoutDir

    Details

    • Epic Link:
    • Similar Issues:
    • Released As:
      PCT 636f22969a8da297bd20a9627ce5db2b91b28a5b

      Description

      Some test flows like essentialsTest() bundle plugins in WEB-INF/plugins. In such case the PCT Docker image run may end up using a wrong version if a user intends to use the version which is already bundled. Using "VERSION" parameter is a solution, but we could also add automatic discovery

        Attachments

          Activity

          Show
          oleg_nenashev Oleg Nenashev added a comment - https://github.com/jenkinsci/plugin-compat-tester/pull/112  

            People

            • Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              oleg_nenashev Oleg Nenashev
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: