Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56280

Swarm client consumes too much memory

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: swarm-plugin
    • Labels:
      None
    • Environment:
      swarm-client-3.13.jar
      Jenkins ver. 2.121.3
    • Similar Issues:

      Description

      I am using swarm-client-3.13.jar to connect Jenkins master 2.121.3. The parameter in slave is following:

      JAVA_ARGS="-Xmx256m -XX:MaxPermSize=512m -Djava.awt.headless=true"

      and in master, it is:

      JAVA_ARGS="-Xmx6144m -XX:MaxPermSize=2048m -Djava.awt.headless=true -Dhudson.slaves.WorkspaceList='-'"
      

      In slave, it consumes VIRT about 8Mb for some days, but it consumes 10Gb after that. Is it a memory leaking issue? Because if I restart swarm-client daemon, its VIRT is 8Mb again, and after some days, it goes back to 10Gb again.

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          Hubert Liit might be a memory leak, but there is not evidence that it is caused by the Swarm Plugin.

          You would need to capture the heapdump at the time of the high memory consumption. Then you will need to analyze it in order to understand what actually causes the issue

          basil Basil Crow added a comment -

          As was mentioned in the previous comment, the out of memory error may have been caused by any Jenkins plugin that runs code agent-side, not necessarily the Swarm client. You might try enabling the -XX:+HeapDumpOnOutOfMemoryError JVM option and then analyzing the heap dump using standard JVM memory analysis techniques to determine the source of the memory utilization. I am closing this issue as "Cannot Reproduce", but if you see evidence pointing to a memory leak in the Swarm client, please open a new issue with detailed steps to reproduce.


            People

            • Assignee:
              Unassigned
              Reporter:
              hubertli Hubert Li
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: