Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56457

Regression in timestamper 1.9: Start of maven plugins is logged with different format

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: timestamper-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.150.3
      All Pipeline plugins pretty much up to date
    • Similar Issues:

      Description

      After the upgrade from 1.8.10 to 1.9 I am seeing strange format changes:

      1.8.10
      12:25:11 [INFO] --- maven-clean-plugin:3.0.0:clean (default-clean) @ root ---
      12:25:11 [INFO] Clean is skipped.
      12:25:11 [INFO] Execution of maven-clean-plugin:3.0.0:clean (default-clean) @ root took 0.063s
      12:25:11 [INFO] 
      12:25:11 [INFO] --- maven-enforcer-plugin:3.0.0-M1-MMS1:enforce (enforce-versions) @ root ---
      12:25:11 [INFO] Skipping Rule Enforcement.
      12:25:11 [INFO] Execution of maven-enforcer-plugin:3.0.0-M1-MMS1:enforce (enforce-versions) @ root took 0.125s
      
      1.9
      [2019-03-07T11:40:27.751Z] [INFO] --- maven-clean-plugin:3.0.0:clean (default-clean) @ root ---
      12:40:27  [INFO] Clean is skipped.
      12:40:27  [INFO] Execution of maven-clean-plugin:3.0.0:clean (default-clean) @ root took 0.049s
      12:40:27  [INFO] 
      [2019-03-07T11:40:27.751Z] [INFO] --- maven-enforcer-plugin:3.0.0-M1-MMS1:enforce (enforce-versions) @ root ---
      12:40:27  [INFO] Skipping Rule Enforcement.
      12:40:27  [INFO] Execution of maven-enforcer-plugin:3.0.0-M1-MMS1:enforce (enforce-versions) @ root took 0.093s
      

      As you can see, the first output of/for a plugin is using a much longer format, whereever this is coming from.

      The pipeline in question is using timestamps() in the options block of the pipeline.

      Once I enable the new option "Enabled for all Pipeline builds", the problem vanishes!

        Attachments

          Issue Links

            Activity

            spoorcc Ben Spoor added a comment -

            Experiencing the same issue, this seems to cause that the IAR console parser in the warnings plugin to get file paths with a timestamp prefixed such as: [2019-03-07T21:31:48.820Z] D:/myworkspace/myfile.c

            leemeador leemeador added a comment -

            Seeing a similar issue.

            CB Jenkins 2.164, Timestamp plugin 1.9.

            If I go to build job and appendĀ /timestamps/?appendlog&elapsed=HH:mm:ss.s it does not show elapsed time and uses the long format UTC time.

            It looks like this:

            [Pipeline] sh
            [2019-06-14T05:36:15.738Z] + env
            [2019-06-14T05:36:15.738Z] + sort
            [2019-06-14T05:36:15.738Z] BUILD_DISPLAY_NAME=#740
            [2019-06-14T05:36:15.738Z] BUILD_ID=740
            [2019-06-14T05:36:15.738Z] BUILD_NUMBER=740

            Similar format appears in api calls:

            String query = 'elapsed=HH:mm:ss.S&appendLog&startLine=-50'
            BufferedReader reader = hudson.plugins.timestamper.api.TimestamperAPI.get().read(build, query)
            reader.withCloseable {
                while ((line = reader.readLine()) != null) {
                    logLines.add(line)
                    println "LOG line read: " + line
                }
            }
            

            Output is

            [Pipeline] echo
            11:13:48  LOG line read:   [2019-06-14T04:01:28.865Z] Removing Streams/Foundation/SequenceConsumer@tmp/
            [Pipeline] echo
            11:13:48  LOG line read:   [2019-06-14T04:01:28.865Z] Removing Streams/Foundation/SequenceConsumerHandler/build/
            [Pipeline] echo
            11:13:48  LOG line read:   [2019-06-14T04:01:28.865Z] Removing Streams/Foundation/SequenceConsumerHandler/com.aa.lookahead.crew.sequence.parser/SequenceMarshaller/
            
            basil Basil Crow added a comment -

            Likely a duplicate of JENKINS-59636, for which I have opened a PR with a fix. I will keep this bug open pending the release of the fix for JENKINS-59636 to verify that the issue is resolved.

            basil Basil Crow added a comment -

            Likely fixed in Timestamper 1.11.1. Falko Modler and leemeador, can you please verify? Thank you!

            basil Basil Crow added a comment -

            It has been a year since the last update on this bug, so I am closing this as a duplicate of JENKINS-59636. If this issue is encountered again, please open a new bug.


              People

              • Assignee:
                basil Basil Crow
                Reporter:
                famod Falko Modler
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: