Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56474

agent stuck in infinite loop at connect time on FreeBSD/arm with openjdk 8


    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: remoting
    • Labels:
    • Environment:
    • Similar Issues:


      Starting an agent (both via ssh and from the command line) on a FreeBSD-12/arm64 agent sends the slave in an infinite loop for over five minutes. If started over ssh, jenkins will try launching a second (and third and so on) copy of the agent to the same result.

      For some reason it did connect once, but I can't reproduce the correct behaviour. I've tried deleting and recreating the host, no changes.

      Attaching stdout, stderr, remoting log and two thread dumps taken a few minutes after startup.

      It would seem that the slave is looping forever in hudson.remoting.ClassFilter$RegExpClassFilter.add - maybe the fact that it's running on an interpreter-mode JVM makes it super inefficient at parsing regexes? Either way, it's been running at 100% CPU for over 15 minutes now and Jenkins still doesn't see the connection as up 


        1. err
          2 kB
        2. out
          0.1 kB
        3. remoting.log.0
          1 kB
        4. tdump.1
          13 kB
        5. tdump.2
          13 kB
        6. tdump.3
          13 kB



            • Assignee:
              jthompson Jeff Thompson
              kinkie kinkie
            • Votes:
              0 Vote for this issue
              3 Start watching this issue


              • Created: