Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56772

Git branch with slashes are double encoded (Jenkins core and blue ocean)

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: blueocean-plugin, core
    • Labels:
    • Environment:
      Jenkins 2.169
      BlueOcean 1.14.0
      Jenkins installed on Windows
      Git Plugin 3.9.3
      Git Client Plugin 2.7.6
    • Similar Issues:

      Description

      I have a GIT Branch called "v10/release".

      1. In default UI of Jenkins, the link of this branch in my "ice" Github repository (/job/ice/)  is  : "/job/ice/job/v10%252Frelease/" (404 error) instead of "/job/ice/job/v10%2Frelease/" which works (display correctly the page, I can execute a build, see logs, etc...)

       note: All branches without slashes work perfectly.

       

      2. In Blue Ocean, Jobs of this branch are listed, but not displayed correctly:

      Example: /blue/organizations/jenkins/ice/detail/v10%2Fmaster/2/pipeline/

      As you can see in my screenshot, urls are also double encoded

       

       

        Attachments

          Activity

          lardef frederic larde created issue -
          lardef frederic larde made changes -
          Field Original Value New Value
          Description I have a GIT Branch called "v10/release".

          1. In default UI of Jenkins, the link of this branch in my "ice" Github repository (/job/ice/)  is  : "/job/ice/job/v10%252Frelease/" (404 error) instead of "/job/ice/job/v10%2Frelease/" which works (display correctly the page, I can execute a build, see logs, etc...)

           

          2. In Blue Ocean, Jobs of this branch are listed, but not displayed correctly:

          Example: /blue/organizations/jenkins/ice/detail/v10%2Fmaster/2/pipeline/

          As you can see in my screenshot, urls are also double encoded

           

           
          I have a GIT Branch called "v10/release".

          1. In default UI of Jenkins, the link of this branch in my "ice" Github repository (/job/ice/)  is  : "/job/ice/job/v10%252Frelease/" (404 error) instead of "/job/ice/job/v10%2Frelease/" which works (display correctly the page, I can execute a build, see logs, etc...)

           note: All branches without slashes work perfectly.

           

          2. In Blue Ocean, Jobs of this branch are listed, but not displayed correctly:

          Example: /blue/organizations/jenkins/ice/detail/v10%2Fmaster/2/pipeline/

          As you can see in my screenshot, urls are also double encoded

           

           
          lardef frederic larde made changes -
          Environment Jenkins 2.169
          BlueOcean 1.14.0
          Jenkins installed on Windows
          Jenkins 2.169
          BlueOcean 1.14.0
          Jenkins installed on Windows
          Git Plugin 3.9.3
          Git Client Plugin 2.7.6
          halkeye Gavin Mogan added a comment -

          so works in classic, fails in blueocean?

          lardef frederic larde added a comment -

          Doesn't work in both case.

          In core: in the GIT repo ("job/ice" url - "ice" is the name of my repo), all links of branches are double encoded => 404

          In blueocean : Links work, but AJAX calls failed (so we have an empty screen)

          lardef frederic larde added a comment -

          Is someone could help me? I will be glad to provide more information if necessary.

          halkeye Gavin Mogan added a comment -

          Honestly there's just too many bugs and not enough people.

          We totally welcome a pull request, but otherwise you'll have to be patient.

          jennbriden Jenn Briden added a comment -

          Hey! Gavin is right – we are fixing top bugs in Blue Ocean but don't always have time to get to everything. I've filed a Request for Enhancement (RFE) for this issue. I'm the lead Product Manager for Jenkins at CloudBees. Thank you for reporting the issue.

          lardef frederic larde added a comment -

          Hi, thanks a lot for your messages. I just wanted to be sure, that this issue was not forgotten.

          halkeye Gavin Mogan added a comment -

          I tried to reproduce it on ci.blueocean and wasn't able to

          https://ci.blueocean.io/blue/organizations/jenkins/Gavin%20Folder%2Fmbtest/detail/slash%2Ftest/1/pipeline

          Can you give me a list of steps starting from https://ci.blueocean.io/job/Gavin%20Folder/ that reproduces the error?

          lardef frederic larde added a comment -

          I'm confused. It seems to work for you. I'm double checking my conf.

          halkeye Gavin Mogan added a comment -

          https://github.com/cb-gmogan-test/mbtest is my test repo

          I'm going to close this for now saying unable to reproduce, but if you can reproduce it, especially in a repo we can use to test with (maybe its with a different scm (git, bitbucket, etc)) feel free to re-open.

          halkeye Gavin Mogan made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Cannot Reproduce [ 5 ]
          lardef frederic larde added a comment -

          I found my issue.

          I have a reverse proxy for HTTPS. Double encoding is Ok and necessary for Jenkins

          My reverse proxy is an IIS server, and after adding in my web.config:

          <system.webServer>

              <security>

                      <requestFiltering allowDoubleEscaping="true" />

              </security>

          </system.webServer>

           

          It works.


            People

            • Assignee:
              Unassigned
              Reporter:
              lardef frederic larde
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: