Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56860

Rebuild plugin records incorrect "Started by user"

    Details

    • Similar Issues:

      Description

      When rebuilding, the new build has the "Started by user" populated with the value from the source build, not the details of the user who requested the rebuild.

      I.e.:

      1. User Alice triggers Build 1 
      2. Build 1 completes and states "Started by user Alice".
      3. User Bob opens Build 1 and clicks "Rebuild", triggering Build 2.
      4. Build 2 completes and states "Started by user Alice" but should have stated "Started by user Bob".

      This creates confusion for accountability and auditing.

      Reverting to Rebuilder plugin 1.29 fixes the issue.

      Two other users have also reported the issue here on the PR for the release which introduced the bug:

      https://github.com/jenkinsci/rebuild-plugin/pull/56#issuecomment-478868354

       

        Attachments

          Activity

          jstangroome Jason Stangroome created issue -
          jstangroome Jason Stangroome made changes -
          Field Original Value New Value
          Description When rebuilding, the new build has the "Started by user" populated with the value from the source build, not the details of the user who requested the rebuild.

          I.e.:
           # User Alice triggers Build 1 
           # Build 1 completes and states "Started by user Alice".
           # User Bob opens Build 1 and clicks "Rebuild", triggering Build 2.
           # Build 2 completes and states "Started by user Alice" but should have stated "Started by user Bob".

          This creates confusion for accountability and auditing.

          Two other users have also reported the issue here on the PR for the release which introduced the bug:

          [https://github.com/jenkinsci/rebuild-plugin/pull/56#issuecomment-478868354]

           
          When rebuilding, the new build has the "Started by user" populated with the value from the source build, not the details of the user who requested the rebuild.

          I.e.:
           # User Alice triggers Build 1 
           # Build 1 completes and states "Started by user Alice".
           # User Bob opens Build 1 and clicks "Rebuild", triggering Build 2.
           # Build 2 completes and states "Started by user Alice" but should have stated "Started by user Bob".

          This creates confusion for accountability and auditing.

          Reverting to Rebuilder plugin 1.29 fixes the issue.

          Two other users have also reported the issue here on the PR for the release which introduced the bug:

          [https://github.com/jenkinsci/rebuild-plugin/pull/56#issuecomment-478868354]

           

            People

            • Assignee:
              ragesh_nair ragesh_nair
              Reporter:
              jstangroome Jason Stangroome
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated: