Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56983

stageFlowNodes never marked as IN_PROGRESS

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Labels:
      None
    • Environment:
      Jenkins 2.164.1 LTS
      Pipeline Stage View Plugin 2.10
    • Similar Issues:

      Description

      When iterating all nodes for a particular job under the `wfapi`, all currently running stageFlowNodes have status "SUCCESS".

       

      Basically what I'm seeing is the topmost entry in `/wfapi` has "status": "IN_PROGRESS", and under stages it'll aslo have "status": "IN_PROGRESS".
       
       

      But hitting the api under the "self" link for the stage (for example `execution/node/17/wfapi/describe`) the response has "status": "IN_PROGRESS", but all stageFlowNodes are "SUCCESS".

      If the execution of one of them fails, it'll change from SUCCESS to FAILED.

       

      This makes it a bit tricky to figure out which of these stageFlowNodes is the one actually marking the stage as "IN_PROGRESS".

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              svanoort Sam Van Oort
              Reporter:
              rdybeck Rickard Dybeck
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: