Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57134

Passing test parameters from Jenkins to ALM for API tests

    Details

    • Similar Issues:

      Description

      [Jenkins][Test Parameters][API] Passing test parameters from Jenkins to ALM does not work for API Tests 

      Steps to reproduce the defect :

      1. Add a parametrized API test in ALM

      2. Create a job of type "Execute Micro Focus functional tests from Micro Focus ALM"

      3. Add test parameters for the API tests

      e.g:

      Root\Jenkins_TestParameters\TestSet "ParamAPI1": "7", "RequestParam1" : "9789000010134"
      4. Execute the job

       

      Expected Result :

      Parameters are not taken into account when running the test in ALM.

      Parameters set in Jenkins should override the actual values set in ALM.

      Actual Result :

       Actual parameters set in ALM are used instead

      Detected in build: ++ 

      Jenkins 5.7

      Regression from version\build (if applicable):

       

      Additional Notes:

      Only for API tests. API test used attached

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              aslaakso Anda Sorina Laakso
              Reporter:
              aslaakso Anda Sorina Laakso
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: