Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57154

Regression in github-oauth-plugin 0.32 breaks /configureSecurity page

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: github-oauth-plugin
    • Labels:
      None
    • Environment:
      OS: Ubuntu 18.04.2 - 64 bit
      Java: openjdk version "1.8.0_191"
      github-oauth-plugin: 0.32
      Jenkins: 2.164.2
    • Similar Issues:
    • Released As:
      github-oauth-0.33

      Description

      After upgrading to github-oauth-plugin 0.32 I started to see this error in /configureSecurity when it tries to retrieve the name of a github user:

      HTTP ERROR 403
      Problem accessing /descriptorByName/hudson.security.ProjectMatrixAuthorizationStrategy/checkName.
      Reason:    Forbidden
      

       

      The first user has its name retrieved successfully but all others have the error mentioned above.

       

      See the attachment users.png.

       

      The workaround for now is revert to 0.31.

        Attachments

          Issue Links

            Activity

            Show
            sag47 Sam Gleske added a comment - Here's the fix https://github.com/jenkinsci/github-oauth-plugin/pull/115
            Hide
            sag47 Sam Gleske added a comment -

            https://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/github-oauth/0.33/github-oauth-0.33.hpi has been release and I verified the fix by upgrading locally to the new version. It should be available in the update center in roughly 8 hours or so.

            Show
            sag47 Sam Gleske added a comment - https://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/github-oauth/0.33/github-oauth-0.33.hpi has been release and I verified the fix by upgrading locally to the new version. It should be available in the update center in roughly 8 hours or so.
            Hide
            joncormier Jon Cormier added a comment -

            I installed 0.33 and the problem no longer appears for me. Thanks Sam Gleske

            Show
            joncormier Jon Cormier added a comment - I installed 0.33 and the problem no longer appears for me. Thanks Sam Gleske
            Hide
            steveims Steve Ims added a comment -

            0.33 working for me too.  Thanks Sam Gleske !

            Show
            steveims Steve Ims added a comment - 0.33 working for me too.  Thanks Sam Gleske !
            Hide
            sag47 Sam Gleske added a comment -

            Jon Cormier Steve Ims no problem; thanks for reporting back your own testing results since it helps me validate the solution was a fix.

            Show
            sag47 Sam Gleske added a comment - Jon Cormier Steve Ims no problem; thanks for reporting back your own testing results since it helps me validate the solution was a fix.

              People

              • Assignee:
                sag47 Sam Gleske
                Reporter:
                franciscocpg Francisco Guimaraes
              • Votes:
                27 Vote for this issue
                Watchers:
                36 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: