Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57213

Blue Ocean changes nodes from red to green after some time

    Details

    • Similar Issues:

      Description

      We have a pipeline running one big `parallel` block in it. Each branch of the `parallel` uses a `build` step to call some downstream job. When one of the downstream builds fail it properly shows it as a failed stage in Blue Ocean UI (see "failed" in attachment). But then after some time (1 hour, a couple of hours, sometimes a day), it turns all red nodes into green (see "failed-but-green" attachment). The same thing happens for `parallel` without `build` step in it but for some reason, it occurs less often.

      It does not happen in all pipelines but happens sometimes for the largest of them. Status of the build itself is still displayed properly (as a failure) and as you can see in "stages" attachment substages of a given Parallel branch are still properly marked as failed. Only the Blue Ocean node becomes green for some reason.

      If I can provide any more details/logs/information, please let me know.

        Attachments

        1. failed.png
          failed.png
          100 kB
        2. failed-but-green.png
          failed-but-green.png
          94 kB
        3. stages.png
          stages.png
          241 kB

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              karolgil Karol Gil
            • Votes:
              4 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: