Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57230

Postbuildscript: NullPointerException

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: postbuildscript-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.150.3 PostBuildScript-plugin 2.8.1
    • Similar Issues:

      Description

      When there is a Jenkins connection issue, the postbuildscript step will fail with the following exception:

      21:30:42 ERROR: Build step failed with exception

      21:30:42 java.lang.NullPointerException

      21:30:42 at org.jenkinsci.plugins.postbuildscript.processor.Processor.<init>(Processor.java:51)

      21:30:42 at org.jenkinsci.plugins.postbuildscript.processor.ProcessorFactory.createDefaultProcessor(ProcessorFactory.java:24)

      21:30:42 at org.jenkinsci.plugins.postbuildscript.processor.ProcessorFactory.createMatrixProcessor(ProcessorFactory.java:35)

      21:30:42 at org.jenkinsci.plugins.postbuildscript.PostBuildScript.createProcessor(PostBuildScript.java:213)

      21:30:42 at org.jenkinsci.plugins.postbuildscript.PostBuildScript.perform(PostBuildScript.java:128)

      21:30:42 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)

      21:30:42 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744)

      21:30:42 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:690)

      21:30:42 at hudson.model.Build$BuildExecution.post2(Build.java:186)

      21:30:42 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:635)

      21:30:42 at hudson.model.Run.execute(Run.java:1835)

      21:30:42 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)

      21:30:42 at hudson.model.ResourceController.execute(ResourceController.java:97)

      21:30:42 at hudson.model.Executor.run(Executor.java:429)

      21:30:42 Build step 'Execute Scripts' marked build as failure

        Attachments

        1. config.xml
          3 kB
        2. screenshot-1.png
          screenshot-1.png
          320 kB
        3. screenshot-2.png
          screenshot-2.png
          101 kB

          Activity

          dheid Daniel Heid added a comment -

          Hi Alfred! Thanks for the ticket. I will investigate the problem...

          dheid Daniel Heid added a comment -

          It's difficult for me to reproduce the problem. Do you have a config.xml for me?

          awong29 Alfred Wong added a comment -

          I have attached the config.xml and you will need to replace with your own credentials.

          dheid Daniel Heid added a comment -

          Thanks for the file and sorry for the delay. I imported your configuration, but still cannot reproduce the problem:

          Are you running Jenkins on Windows?

          awong29 Alfred Wong added a comment -

          The jenkins master is Linux and the slaves are Windows.

          dheid Daniel Heid added a comment -

          Sorry, but even using your provided config.xml on Windows I could not reproduce the problem:


            People

            • Assignee:
              dheid Daniel Heid
              Reporter:
              awong29 Alfred Wong
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: