Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57319

HockeyApp Plugin "unexpected response code from HockeyApp: 400"

    Details

    • Similar Issues:
    • Released As:
      1.5.1

      Description

      Hello,

      I am currently using Hockey App Plugin to upload iOS .ipa files to Hockey app. Right now i'm facing an issue with API Token. Last day my Hockeyapp plugin has been removed from Jenkins , so today i have installed it again , before installing i have seen warning under the plugin says 

      Version 1.5.0 (1st May 2019)
      • JENKINS-57005 Favour Secret tokens over String tokens (#60 )
        • Note: Versions prior to 1.5.0 store tokens in plain text. You should consider these compromised and reconfigure you existing jobs.

      After installing the HockeyApp Plugin, i had run my jobs and it's throwing me "No API Token" error in Jenkins. Below are the detail error in jenkins

      Got unexpected response code from HockeyApp: 400
      {"errors":{"credentials":["no api token"]}}

      What might be the issue? Do i need to add the Token in the Jenkins existing jobs?  

       

      Note: I have Hockey-app configuration AppKey and AppID in my project plist file. My Jenkins pipeline reads the HockeyApp configuration from the plist.

       

        Attachments

          Activity

          Hide
          mezpahlan Mez Pahlan added a comment -

          Hi Madhu A I've made a fix that I think might work for both types of project freestyle and pipeline. Would you mind testing 1.5.1 out before I merge it.

          You can find 1.5.1 on the CI server https://ci.jenkins.io/blue/organizations/jenkins/Plugins%2Fhockeyapp-plugin/detail/PR-61/2/artifacts

          And the associated Github PR:

          https://github.com/jenkinsci/hockeyapp-plugin/pull/61

          Thanks

          Show
          mezpahlan Mez Pahlan added a comment - Hi Madhu A I've made a fix that I think might work for both types of project freestyle and pipeline. Would you mind testing 1.5.1 out before I merge it. You can find 1.5.1 on the CI server https://ci.jenkins.io/blue/organizations/jenkins/Plugins%2Fhockeyapp-plugin/detail/PR-61/2/artifacts And the associated Github PR: https://github.com/jenkinsci/hockeyapp-plugin/pull/61 Thanks
          Hide
          madhuailp Madhu A added a comment -

          Mez Pahlan Thank you for your help, rolled back to version 1.4.0 and that did the job for me. Much appreciate your help. Cheers 

          Show
          madhuailp Madhu A added a comment - Mez Pahlan Thank you for your help, rolled back to version 1.4.0 and that did the job for me. Much appreciate your help. Cheers 
          Hide
          mezpahlan Mez Pahlan added a comment -

          If you've uninstalled the plugin and reinstalled then maybe that's why you don't see the downgrade option. But either way you should be able to get the old version from the build server.

          https://ci.jenkins.io/job/Plugins/job/hockeyapp-plugin/job/master/28/

          Show
          mezpahlan Mez Pahlan added a comment - If you've uninstalled the plugin and reinstalled then maybe that's why you don't see the downgrade option. But either way you should be able to get the old version from the build server. https://ci.jenkins.io/job/Plugins/job/hockeyapp-plugin/job/master/28/
          Hide
          madhuailp Madhu A added a comment -

          Mez Pahlan Thanks for responding back, but I don't see any option to roll back to Hockey App version 1.4.0 in my jenkins. There is downgrade option. Is there any way we can do that?

          Show
          madhuailp Madhu A added a comment - Mez Pahlan  Thanks for responding back, but I don't see any option to roll back to Hockey App version 1.4.0 in my jenkins. There is downgrade option. Is there any way we can do that?
          Hide
          mezpahlan Mez Pahlan added a comment -

          Hi there thanks for reporting there is a known issue with 1.5.0 and pipelines. I suggest rolling back for now whilst I look into it.

          Show
          mezpahlan Mez Pahlan added a comment - Hi there thanks for reporting there is a known issue with 1.5.0 and pipelines. I suggest rolling back for now whilst I look into it.

            People

            • Assignee:
              mezpahlan Mez Pahlan
              Reporter:
              madhuailp Madhu A
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: