Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57450

Update delivery pipeline plugin to support JDK11 build environment (current LTS Java version)

    Details

    • Similar Issues:

      Description

      Builds under JDK11 currently fail. Most failures are due to transitive dependencies upon packages that access internal sun package elements.

      As of the completion of project Jigsaw in Java 9 access to these elements produce compile time failures, so the plugin as it stands cannot be built under Java 11.

        Attachments

          Activity

          Hide
          dcminter Dave Minter added a comment -

          A candidate change set is on branch jdk11.

          Show
          dcminter Dave Minter added a comment - A candidate change set is on branch jdk11.
          Hide
          tommysdk Tommy Tynjä added a comment -

          Proposed solution has been merged to master (https://github.com/Diabol/delivery-pipeline-plugin/pull/298). Will be part of the next  delivery pipeline plugin release.

           

          Show
          tommysdk Tommy Tynjä added a comment - Proposed solution has been merged to master ( https://github.com/Diabol/delivery-pipeline-plugin/pull/298). Will be part of the next  delivery pipeline plugin release.  
          Hide
          tommysdk Tommy Tynjä added a comment -

          Released in Delivery Pipeline plugin 1.4.0.

          Show
          tommysdk Tommy Tynjä added a comment - Released in Delivery Pipeline plugin 1.4.0.

            People

            • Assignee:
              dcminter Dave Minter
              Reporter:
              dcminter Dave Minter
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: