Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5775

HTML Publisher plugin 0.2.2 - Report link missing after bounce

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: htmlpublisher-plugin
    • Labels:
      None
    • Environment:
      Development
    • Similar Issues:
      Show 5 results

      Description

      In Hudson, we use HTML publisher to archieve the reports. Whenever the Hudson is re-started (Server reboot) , the reports link shown on the builds within the job are getting de-linked and showns "Jobname - #BuildNumber"

      Snap shot is attached for your reference..
      1)Build with link available
      2)After bounce - Build with invalid link

      Thanks
      Balaji

        Attachments

        1. After bounce  -  Build with invalid link.JPG
          After bounce - Build with invalid link.JPG
          16 kB
        2. Build with link enabled.JPG
          Build with link enabled.JPG
          14 kB
        3. hudson_err.zip
          2 kB
        4. HUDSON-5775.patch
          4 kB
        5. HUDSON-5775-ver2.patch
          2 kB
        6. log.zip
          2 kB

          Activity

          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : mcrooney
          Path:
          trunk/hudson/plugins/htmlpublisher/src/main/java/htmlpublisher/HtmlPublisherTarget.java
          http://jenkins-ci.org/commit/30883
          Log:
          [htmlpublisher] apply patch to fix JENKINS-5775 for future builds of job-level reports

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : mcrooney Path: trunk/hudson/plugins/htmlpublisher/src/main/java/htmlpublisher/HtmlPublisherTarget.java http://jenkins-ci.org/commit/30883 Log: [htmlpublisher] apply patch to fix JENKINS-5775 for future builds of job-level reports
          Hide
          mcrooney mcrooney added a comment -

          Thanks so much, I've tested and committed the v2 patch and will release it in the next version, at least fixing this for future builds. Since the reports for previous builds are still there, I wonder if there is a way to restore them?

          Show
          mcrooney mcrooney added a comment - Thanks so much, I've tested and committed the v2 patch and will release it in the next version, at least fixing this for future builds. Since the reports for previous builds are still there, I wonder if there is a way to restore them?
          Hide
          arostfx arostfx added a comment -

          Hello,

          thanks a lot for your help. I've upgraded to plugin version 0.3 now (Hudson 1.358).
          With that, upon report creation, I get Java errors on the Hudson console now. The reports are created, though.
          Could you please check?

          Thanks,
          /alex

          Show
          arostfx arostfx added a comment - Hello, thanks a lot for your help. I've upgraded to plugin version 0.3 now (Hudson 1.358). With that, upon report creation, I get Java errors on the Hudson console now. The reports are created, though. Could you please check? Thanks, /alex
          Hide
          arostfx arostfx added a comment -

          Hudson errors from plugin version 0.3 and Hudson 1.358

          Show
          arostfx arostfx added a comment - Hudson errors from plugin version 0.3 and Hudson 1.358
          Hide
          mcrooney mcrooney added a comment -

          It would be best to open up a new bug for that please, thanks!

          Show
          mcrooney mcrooney added a comment - It would be best to open up a new bug for that please, thanks!

            People

            • Assignee:
              mcrooney mcrooney
              Reporter:
              balajirangarajan balajirangarajan
            • Votes:
              6 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: