Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57857

Dashboard - 'Select subset of tools' not working with multiple charts

    Details

    • Similar Issues:
    • Released As:
      6.1.0

      Description

      When wanting to display the statistics or chart with a subset of tools, the only option available is analysis and if I try to manually add the id of a tool, no statistics or chart is displayed.

       

       

       

        Attachments

          Activity

          Hide
          drulli Ulli Hafner added a comment -

          Did you aggregate the results into the analysis action?

          Show
          drulli Ulli Hafner added a comment - Did you aggregate the results into the analysis action?
          Hide
          julieshamji Julie Shamji added a comment -

          Thanks Ulli, I did have aggregate on so last night I changed the configuration not to aggregate. This morning, I cannot see the previous aggregated results so added tool specific charts and these are still blank and the chart without a subset selected is not blank.

          Show
          julieshamji Julie Shamji added a comment - Thanks Ulli, I did have aggregate on so last night I changed the configuration not to aggregate. This morning, I cannot see the previous aggregated results so added tool specific charts and these are still blank and the chart without a subset selected is not blank.
          Hide
          julieshamji Julie Shamji added a comment -

          Please note that the chart without the subset set has counts which no not total correctly as well.

          Show
          julieshamji Julie Shamji added a comment - Please note that the chart without the subset set has counts which no not total correctly as well.
          Hide
          drulli Ulli Hafner added a comment -

          I think it would make sense to wait a couple of days to have some meaningful data for the chart.

          Show
          drulli Ulli Hafner added a comment - I think it would make sense to wait a couple of days to have some meaningful data for the chart.
          Hide
          julieshamji Julie Shamji added a comment -

          Hi Ulli,

           

          I have done some further testing. If I remove all the charts, then add a chart with no subset, I see the chart with the correct numbers. If I think add another chart with a different name with a subset, the first chart displayed with the subset counts instead of all counts and the other is blank when that one should display what the first is displaying. So the issue is when multiple charts are configured on the same dashboard with different settings, the last one is used for the first chart and all other charts are blank.

          Show
          julieshamji Julie Shamji added a comment - Hi Ulli,   I have done some further testing. If I remove all the charts, then add a chart with no subset, I see the chart with the correct numbers. If I think add another chart with a different name with a subset, the first chart displayed with the subset counts instead of all counts and the other is blank when that one should display what the first is displaying. So the issue is when multiple charts are configured on the same dashboard with different settings, the last one is used for the first chart and all other charts are blank.

            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              julieshamji Julie Shamji
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: