Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57879

Build number increments by more than 1

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: git-parameter-plugin
    • Labels:
      None
    • Environment:
      Jenkins latest version (2.164.3) with Git-parameter plugin 0.9.10
    • Similar Issues:

      Description

      In all my jobs where I use Git Parameters (used to select branch/tag for several repos), my build number increments by 2 (and in certain cases increments even by 3 or more)

      When Git-Parameter is not used, build numbers increment always by 1, as it should.

      I have seen many related issues, which are now closed, but they are not actually fixed as I'm facing the same problem.

      Reproducing it should be easy. Just create a pipeline job and use Git-Parameter (I use two Git Parameters in my job)

        Attachments

          Activity

          klimas7 Boguslaw Klimas added a comment -

          Hi,

          I released plugin in version 0.9.11 where this issue was resolved, could you check that and confirm the issue is resolved

           
          Regards
          Boguslaw

          carlosgarcia Carlos Garcia added a comment -

          Yes, I can confirm that the problem is now solved with version 0.9.11,

           

          Thank you very much! 


            People

            • Assignee:
              klimas7 Boguslaw Klimas
              Reporter:
              carlosgarcia Carlos Garcia
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: