Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58194

Unsatisfied dependencies gitlab-hook

    Details

    • Similar Issues:

      Description

      Hi, I am new to Jenkins and DevOps, and I am trying to install the ruby-runtime plugin as I have received this warning message:

      Correct
      Dependency errors:

      Some plugins could not be loaded due to unsatisfied dependencies. Fix these issues and restart Jenkins to restore the functionality provided by these plugins.

      Gitlab Hook Plugin version 1.4.2
      ruby-runtime version 0.12 is missing. To fix, install version 0.12 or later.

      however, I have downloaded the ruby-runtime plugin three times, as well as restarted Jenkins. Why is it not showing up in my installed plugins?

        Attachments

          Activity

          Hide
          tollaska Elek Akos added a comment -

          Install Java 8 

          java version "1.8.0_231"
          Java(TM) SE Runtime Environment (build 1.8.0_231-b11)
          Java HotSpot(TM) 64-Bit Server VM (build 25.231-b11, mixed mode)
          
          Show
          tollaska Elek Akos added a comment - Install Java 8  java version "1.8.0_231" Java(TM) SE Runtime Environment (build 1.8.0_231-b11) Java HotSpot(TM) 64-Bit Server VM (build 25.231-b11, mixed mode)

            People

            • Assignee:
              javiplx Javier Palacios
              Reporter:
              ktrawizki Kaila Trawitzki
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: