Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58242

Look into Failed Junit Test on Ubuntu

    Details

    • Similar Issues:
    • Sprint:
      GSoC 2019. Coding Phase 2, GSoC 2019. Coding Phase 3

      Description

      The junit test for bundled plugins is failing on Ubuntu but didn't on Mac. The following error was thrown. 

      java.lang.reflect.InaccessibleObjectException: Unable to make boolean jdk.nio.zipfs.ZipFileSystem.isDirectory(byte[]) throws java.io.IOException accessible: module jdk.zipfs does not "opens jdk.nio.zipfs"

      This might be due to differences in jdks. We might want to add a note in the documentation about what jdks the tool is compatible with. 

        Attachments

          Issue Links

            Activity

            stopalopa Natasha Stopa created issue -
            stopalopa Natasha Stopa made changes -
            Field Original Value New Value
            Epic Link JENKINS-53767 [ 194275 ]
            oleg_nenashev Oleg Nenashev made changes -
            Sprint GSoC 2019. Coding Phase 2 [ 691 ] GSoC 2019. Coding Phase 2, GSoC 2019. Coding Phase 3 [ 691, 696 ]
            kwhetstone Kristin Whetstone added a comment -

            I don't think that we're hitting this anymore? I think we can close.

            stopalopa Natasha Stopa added a comment -

            Actually, I don't think I've tested on Linux since then. I can also add re-testing it to my TODO list for this week.

            kwhetstone Kristin Whetstone added a comment -

            The tests with `buildPlugin` should cover this as it tests on linux and windows. I think this is safe to close.

            stopalopa Natasha Stopa added a comment -

            After looking into this a little more, it seems that I was using Java 11 on my Ubuntu vm, and by default buildPlugins only tests for Java 8 (https://github.com/jenkins-infra/pipeline-library).  I don't really fully understand the error yet, but it seems to be caused by a change introduced in Java 11. I'll close this ticket and open a separate one about adding compatibility with Java 11. 

            stopalopa Natasha Stopa made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            stopalopa Natasha Stopa made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            stopalopa Natasha Stopa added a comment -

            Closing this since investigation into what was causing the issue was completed. Opened a separate ticket for actually resolving the issue:

            https://issues.jenkins-ci.org/browse/JENKINS-59173

            stopalopa Natasha Stopa made changes -
            Link This issue is related to JENKINS-59173 [ JENKINS-59173 ]
            stopalopa Natasha Stopa made changes -
            Status In Review [ 10005 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]

              People

              • Assignee:
                stopalopa Natasha Stopa
                Reporter:
                stopalopa Natasha Stopa
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: