Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58296

Projects are triggered twice when using File Parameter and Firefox 67

    Details

    • Similar Issues:
    • Released As:
      jenkins-2.202

      Description

      Projects are triggered twice, when using "File Parameter" in "Build with Parameters"

      Issue appears with Jenkins 2.176.1, Paramized Trigger Plugin 2.35.2 and Firefox 67.0.4

      No issue with Jenkins 2.164.1 Paramized Trigger Plugin 2.35.2 and Firefox 67.0.4
      No issue with Jenkins 2.176.1, Paramized Trigger Plugin 2.35.2 and Firefox 60.6.1esr
      No issue with Chrome

        Attachments

          Issue Links

            Activity

            torstenboelting Torsten Boelting created issue -
            jnutzman Josh Nutzman added a comment -

            I've also had this issue on Firefox/Mac 68.0

            Jenkins 2.176.1

             

            Chrome 75.0.3770.100 worked correctly.

            andrey_grig Andrey Grig added a comment -

            Hi,

            I've also had this issue on Windows/OSX & Firefox 68.0.1

            Jenkins 2.181

            Any ETA for fix this bug?

             

            Thanks in advance.

            mikhail_a Mikhail Asiatici added a comment -

            I'm also having this issue on Firefox 69.0 on Windows 10 and Ubuntu 18.04.2. Jenkins 2.176.3 LTS. No problems with Chrome, Internet Explorer or Microsoft Edge.

            awalls Alejandro Jurado Walls made changes -
            Field Original Value New Value
            Component/s parameterized-trigger-plugin [ 15592 ]
            awalls Alejandro Jurado Walls made changes -
            Environment Jenkins 2.176.1, Paramized Trigger Plugin 2.35.2, Firefox 67.0.4 Jenkins 2.176.1, Parameterized Trigger Plugin 2.35.2, Firefox 67.0.4
            awalls Alejandro Jurado Walls made changes -
            Labels firefox
            dnusbaum Devin Nusbaum added a comment -

            Seems related to JENKINS-53462, JENKINS-58996, JENKINS-54333, etc.

            dnusbaum Devin Nusbaum made changes -
            Link This issue relates to JENKINS-53462 [ JENKINS-53462 ]
            dnusbaum Devin Nusbaum made changes -
            Link This issue relates to JENKINS-54333 [ JENKINS-54333 ]
            dnusbaum Devin Nusbaum added a comment -

            I would close this as a duplicate of JENKINS-54333, but it looks like users are seeing this in 2.173+, and the last comment in that ticket indicates that 2.173 has the most recent change related to this issue, so maybe there is something distinct here.

            mikhail_a Mikhail Asiatici added a comment -

            I indeed see it even in 2.190.1.

            tom_gl Thomas de Grenier de Latour added a comment -

            I've not tried 2.190.1 yet, but I can definitely reproduce this double-submit issue with Firefox 68.1.0esr and 70.0b10, and Jenkins 2.176.3, as soon as there are file parameters for a job. I don't think "Parameterized Trigger Plugin" has anything to do with this issue, it can be reproduced while running Jenkins from sources with "mvn org.jenkins-ci.tools:maven-jenkins-dev-plugin:run", which doesn't include this plugin.
            And I definitely can't reproduce if using Firefox 66, the latest version available on Ubuntu Trusty (I've not tried 67).

            Also, I see the same issue in the plugins manager (running from Jenkins sources on the 2.176.3 tag):

            • go to /jenkins/pluginManager/advanced
            • select some random file to upload (don't bother picking a real .hpi if you don't actually want to install a plugin)
            • submit (with Firefox dev tools enabled on network monitor)
            • notice that there are 2 identical POST requests sent for /jenkins/pluginManager/uploadPlugin
              (and in case you actually upload a .hpi plugin, you'll see in Jenkins log that there are two attempts at loading it, with the later in failure)

            Of course I can't say for sure that the "file parameters" bug on jobs and the ".hpi plugin upload" bug are indeed the same bug, but it sounds really very similar.

            Oh, and I've tried reverting acc4eec688a (from #3761 / JENKINS-53462), again on 2.176.3 sources: it fixes the issue both for running jobs with file parameters, and for uploading a file to the plugins manager. Actually, with this commit reverted, it seems that everything works fine in these two forms, both in FF 66 and 70. And running a job with no file parameter (only a string parameter) works fine too, so I'm starting to doubt this change was really necessary (my understanding of JENKINS-53462 was that form submission without this patch should have broke in recent FF versions).

            tom_gl Thomas de Grenier de Latour added a comment -

            I'm starting to doubt this change was really necessary (my understanding of JENKINS-53462 was that form submission without this patch should have broke in recent FF versions)

            Latest comments from https://bugzilla.mozilla.org/show_bug.cgi?id=1370630 suggest that this "upcoming" change to FF which was requiring acc4eec688a (#3761 / JENKINS-53462) has actually been backed out during the 69 beta cycle (it was also never merged in FF 68, and there is no mention of a merge in FF 70 in this bugzilla issue). This explains that, I guess... The only remaining mystery (for me, but I might also be misinterpreting everything) is that Jenkins 2.176.3 actually works fine (including when submitting forms with file inputs) in FF 66.

            tom_gl Thomas de Grenier de Latour made changes -
            Remote Link This issue links to "PR #4246 (Web Link)" [ 23739 ]
            danielbeck Daniel Beck made changes -
            Labels firefox firefox lts-candidate
            danielbeck Daniel Beck made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            Released As jenkins-2.202
            olivergondza Oliver Gondža made changes -
            Labels firefox lts-candidate 2.190.3-fixed firefox

              People

              • Assignee:
                Unassigned
                Reporter:
                torstenboelting Torsten Boelting
              • Votes:
                11 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: