Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58496

Jenkins prefix doesn't work (HTTP ERROR 404)

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: docker
    • Labels:
      None
    • Similar Issues:

      Description

      I have a job which runs the following command;
      sudo docker run d p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" --env JENKINS_ARGS="-prefix=/jenkins" ${ImageID}

      However, Jenkins is not starting with the Prefix:

      HTTP ERROR 404

      Problem accessing /jenkins. Reason:  Not Found

      any idea where I can see more info on why it's not working?

        Attachments

          Activity

          arielma Ariel M created issue -
          arielma Ariel M made changes -
          Field Original Value New Value
          Description I have a job which runs the following command;
          sudo docker run -d -p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" {color:#DE350B}--env JENKINS_ARGS="--prefix=/jenkins{color}" ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          I have a job which runs the following command;
          sudo docker run -d -p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" *--env JENKINS_ARGS="--prefix=/jenkins*" ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          arielma Ariel M made changes -
          Description I have a job which runs the following command;
          sudo docker run -d -p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" *--env JENKINS_ARGS="--prefix=/jenkins*" ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          I have a job which runs the following command;
           sudo docker run d -p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" ***env JENKINS_ARGS="-prefix=/jenkins*" ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          arielma Ariel M made changes -
          Description I have a job which runs the following command;
           sudo docker run d -p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" ***env JENKINS_ARGS="-prefix=/jenkins*" ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          I have a job which runs the following command;
           sudo docker run d -p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" **--*env JENKINS_ARGS="-prefix=/jenkins*" ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          arielma Ariel M made changes -
          Description I have a job which runs the following command;
           sudo docker run d -p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" **--*env JENKINS_ARGS="-prefix=/jenkins*" ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          I have a job which runs the following command;
           sudo docker run d p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" {color:#de350b}--*env JENKINS_ARGS="-prefix=/jenkins*"{color} ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          arielma Ariel M made changes -
          Summary Jenkins prefix doesn't work Jenkins prefix doesn't work (HTTP ERROR 404)
          Description I have a job which runs the following command;
           sudo docker run d p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" {color:#de350b}--*env JENKINS_ARGS="-prefix=/jenkins*"{color} ${ImageID}

          However, Jenkins is not starting with the Prefix. any idea where I can see more info on why it's not working?
          I have a job which runs the following command;
           sudo docker run d p ${Jenkins_PORT}:8080 -p ${Jenkins_TCP_PORT}:50000 --name ${Conatiner_name} -e TZ=Asia/Jerusalem -v /pciuser/tools/jenkins/${Conatiner_name}/jenkins-production:/var/jenkins_home --env JAVA_OPTS="-Xmx2048m" {color:#de350b}--*env JENKINS_ARGS="-prefix=/jenkins*"{color} ${ImageID}

          However, Jenkins is not starting with the Prefix:

          HTTP ERROR 404

          Problem accessing /jenkins. Reason:  Not Found

          any idea where I can see more info on why it's not working?
          Hide
          arielma Ariel M added a comment -

          I had to use the below param:

          env JENKINS_OPTS="-prefix=/jenkins

          Show
          arielma Ariel M added a comment - I had to use the below param: env JENKINS_OPTS=" -prefix=/jenkins
          arielma Ariel M made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          arielma Ariel M made changes -
          Status Resolved [ 5 ] Fixed but Unreleased [ 10203 ]

            People

            • Assignee:
              csanchez Carlos Sanchez
              Reporter:
              arielma Ariel M
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: