Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58504

P4 Plugin tries to make depot location of Jenkinsfile available regardless of SCM type

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: p4-plugin
    • Labels:
    • Environment:
      Jenkins ver. 2.176.1
      P4 Plugin v 1.10.2
    • Similar Issues:

      Description

      https://github.com/jenkinsci/p4-plugin/blob/master/src/main/java/org/jenkinsci/plugins/p4/PerforceScm.java#L545

      This code was added to address JENKINS-39107. We have a use-case where our jobs use lightweight checkout to load build scripts from gitlab, but the Jenkinsfiles themselves checkout from p4 to get the actual code that we build.

      The added code then tries to run 'p4 where' on the Jenkinsfile, but it doesn't exist in p4. This doesn't cause any build failures, but does print the following message:

      16:26:55  (p4):cmd:... p4 where E:\workspace\folder\to\Jenkinsfile.groovy 
      16:26:55  p4 where E:\workspace\folder\to\Jenkinsfile.groovy
      16:26:55 E:\workspace\folder\to\Jenkinsfile.groovy - file(s) not in client view.
      

       which causes our failure tracking to erroneously pick it up (because it's a legitimate failure at times in other cases).

        Attachments

          Activity

          p4karl Karl Wirth added a comment -

          Hi Aaron Ling, Thanks for letting us know. I will try and repro this here and get back to you if we need any more information.

          p4karl Karl Wirth added a comment -

          Hi Aaron Ling - I haven't been able to reproduce this with a simple Pipeline job that syncs Jenkinsfile from GitHub then runs 'p4sync' in the Jenkinsfile.

          Where are you seeing the error message? Is it in the console log or elsewhere (such as the polling log).

          I'd like to see the following items. Would you be able to email them to support@perforce.com referencing this defect?

          1. Screenshots of Job config
          2. Directory listing of Git repo master branch
          3. Jenkinsfile
          4. Console log (or other log) showing the problem.

          Thanks in advance,

          Karl

           

          p4paul Paul Allen added a comment -

          Released in 1.10.3


            People

            • Assignee:
              p4paul Paul Allen
              Reporter:
              aaronling Aaron Ling
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: