Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5852

Console output no longer escapes <

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Current svn trunk
    • Similar Issues:
      Show 5 results

      Description

      r28173 (annotators for console output) changed st:copyStream to it.writeToLog in Run/console.jelly. One function of st:copyStream is escaping of < and & characters, and it appears the new code doesn't do this.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/java/hudson/AbstractMarkupText.java
            trunk/hudson/main/core/src/main/java/hudson/MarkupText.java
            trunk/hudson/main/core/src/main/java/hudson/console/ConsoleAnnotationOutputStream.java
            trunk/hudson/main/core/src/main/java/hudson/scm/ChangeLogSet.java
            trunk/hudson/main/core/src/test/java/hudson/MarkupTextTest.java
            trunk/hudson/main/test/src/test/java/hudson/console/ConsoleAnnotatorTest.java
            trunk/www/changelog.html
            http://jenkins-ci.org/commit/28418
            Log:
            [FIXED JENKINS-5852] '<' and '&' in the console output was not escaped since 1.349

            fmhome fmhome added a comment -

            This issue is now came back with the latest Hudson Release.

            Hudson Version = 1.352

            mindless Alan Harder added a comment -

            I don't see a problem with current svn. Can you reproduce the problem using "java -jar hudson.war" with Hudson 1.353 to create a new Hudson install? What are the steps to see the problem?

            fmhome fmhome added a comment -

            Sorry about that, i entered the comments in the wrong issue.
            I accidently re-opened this issue, you can close it now.


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                mindless Alan Harder
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: