Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5866

AbstractMethodError from SCM.poll

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Linux, JDK 6. 1.349 w/ Mercurial plugin 1.25.
    • Similar Issues:

      Description

      I upgraded two Hudson servers, both using latest Mercurial plugin, to Hudson 1.349. One seems fine. On the other one, SCM polling is completely broken (for jobs built either on master or slaves):

      Last Mercurial Polling Log

      Started on Mar 8, 2010 5:31:08 PM
      ERROR: Failed to record SCM polling
      [8mha:AAA....<junk>....AAA==[0mjava.lang.AbstractMethodError
      at hudson.scm.SCM.poll(SCM.java:344)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1149)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:319)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:348)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)

      The stack trace is odd because it looks like it is throwing AME from inside the catch block for AME, calling the older method!

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Seems related to fix of JENKINS-2180.

            jglick Jesse Glick added a comment -

            Seems to be working after a restart of the server, for no reason I can explain.

            kohsuke Kohsuke Kawaguchi added a comment -

            "Working after a restart" is the same symptom as Fabrizio reported in http://n4.nabble.com/HG-polling-broken-after-the-latest-update-td1565296.html

            I still can't reproduce this problem.

            jglick Jesse Glick added a comment -

            Yes, my experience is exactly the same as Fabrizio's. Perhaps the Hudson plugin class loader is loading certain classes from the old JAR? But even that would not explain the stack trace (that I can see), since the caller is in the exact same class as the definition of the method which is no longer abstract.

            abayer Andrew Bayer added a comment -

            I was able to reproduce it by having both a git job and a Subversion job (with Subversion plugin 1.12 or later), with both polling. So I'm guessing there's some bleed there.

            jglick Jesse Glick added a comment -

            Started happening again today on the same server. (This one does have a few Subversion-based jobs as well as Mercurial-based jobs, whereas the server which is OK has only Mercurial-based jobs.)

            jglick Jesse Glick added a comment -

            I just released mercurial.hpi 1.26 which uses the new API; maybe that will help.

            abayer Andrew Bayer added a comment -

            Closing this, since it's a duplicate of JENKINS-5756

            abayer Andrew Bayer added a comment -

            FYI, @jglick, your new release of the Mercurial plugin is going to run into the same problem seen in JENKINS-5827. See what we're doing in SubversionSCM.compareRemoteRevisionWith(...) to see how to fix that.


              People

              • Assignee:
                Unassigned
                Reporter:
                jglick Jesse Glick
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: