Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5869

Console output during build does not wrap in IE

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Hudson version: 1.353
      Subversion Plugin version: 1.16
    • Similar Issues:

      Description

      I have upgraded Hudson and my Subversion plugin to the latest version recently and I am getting the odd behavior of subversion plugin.
      The logfile shows in the console output is not properly formatted as it used to and spitting continous lines.

      The raw output looks ok though.

      Can someone please fix it as it is really hard to monitor the actual build in progress.

      Thanks

        Attachments

          Activity

          mindless Alan Harder added a comment -

          Can you be more specific? What output in the console? Everything from the job goes there, so I guess you're talking about the svn update or checkout part of it?
          Did you upgrade only Subversion plugin and then this problem appeared, or did you upgrade Hudson itself too? If Hudson was upgraded to 1.349, then JENKINS-5852 may be involved.. any < characters in the output?

          fmhome fmhome added a comment -

          I am sure, this is a similar issue as JENKINS-5852.

          I have upgraded both Subversion Plugin and Hudson.

          BTW, this works fine in Firefox but not in IE. It used to work fine in both browsers before Hudson 1.349

          Thanks

          mindless Alan Harder added a comment -

          It's really hard to help unless you can be more specific.. now you've mentioned this is browser specific, but what version(s) of IE are you talking about? And what exactly is the problem behavior you see? My questions above were not answered..

          fmhome fmhome added a comment -

          What output in the console?
          After starting the job and when you open the 'console output'. Like SVN checkout, or anything you compile.
          This is happening in IE 8 and not happening in FF 3.6.

          Did you upgrade only Subversion plugin and then this problem appeared, or did you upgrade Hudson itself too?
          I have upgraded both Subversion Plugin and Hudson.

          any < characters in the output?
          No

          mindless Alan Harder added a comment -

          Let us know if the problem still exists in Hudson 1.350 so we know for sure whether JENKINS-5852 is related or not.

          fmhome fmhome added a comment -

          Thanks, the problem is fixed in Hudson v1.350

          fmhome fmhome added a comment -

          This issue is now came back with the latest Hudson Release.

          Hudson Version = 1.353

          fmhome fmhome added a comment -

          The svn plugun version is v1.16

          mindless Alan Harder added a comment -

          Please provide all the details request above, again.
          Also please post an excerpt of a build log showing this problem, thanks.

          fmhome fmhome added a comment - - edited

          I have updated the env section and attached the screenshot.

          The rest of the info is same as in the above comments.

          mindless Alan Harder added a comment -

          Confirmed.. I see this in IE7 too.
          The console during the build has this problem, but a completed build looks OK.

          mindless Alan Harder added a comment -

          Not related to subversion plugin, just logText/progressiveHtml.

          mindless Alan Harder added a comment - - edited

          OK, the cause of the problem is this:
          http://www.quirksmode.org/bugreports/archives/2004/11/innerhtml_and_t.html

          How IE handles assigning text to "innerHTML" of an element.. the newlines sent by Hudson are "normalized" (in this case, lost).

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : mindless
          Path:
          trunk/hudson/main/core/src/main/resources/lib/hudson/progressiveText.jelly
          trunk/www/changelog.html
          http://jenkins-ci.org/commit/29722
          Log:
          [FIXED JENKINS-5869] workaround in progressive log display for IE's
          whitespace normalization when assigning to innerHTML.

          cdauth cdauth added a comment -

          The issue is still present in 1.354. Has the fix been included?

          torbent torbent added a comment -

          I noticed the same. I also noticed that it wasn't mentioned in the (visible) Changelog, so I assume it was excluded from the release for some reason?

          mindless Alan Harder added a comment -

          it was committed after 1.354 cutoff, so it will be in 1.355

          torbent torbent added a comment -

          Works nicely in 1.355, yes


            People

            • Assignee:
              mindless Alan Harder
              Reporter:
              fmhome fmhome
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: