Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-58704

Flaky downstream job link display

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: blueocean-plugin
    • Labels:
      None
    • Environment:
      Windows 2016
      Blue Ocean 1.18 (the bug exists since at least 1.16)
    • Similar Issues:

      Description

      Blue Ocean doesn't always link to a new job's build.

       

      Calling pipeline:

      calling.groovy

       

      Invoked pipeline:

      invoked.groovy

       

      In the attached screenshots you can see that the first invocation (0.png) has the downstream link, whereas the second invocation (1.png) only has a log entry.

      In the console log we can see something even stranger - the same build number is used for all three builds. Anyway, this behavior doesn't happen in any of my real pipelines, but the downstream link display problem does.

        Attachments

        1. 0.png
          0.png
          35 kB
        2. 1.png
          1.png
          32 kB
        3. calling.groovy
          0.4 kB
        4. consolelog.png
          consolelog.png
          37 kB
        5. invoked.groovy
          0.2 kB

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              towel Yoav Miles
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: